Magento Forum

   
Can’t upgrade to 1.1.5 “magento-core/Lib_Varien requires PHP extension “mcrypt"” [RESOLVED]
 
Tom D.
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2008-08-17
Canada
 

Can’t upgrade to 1.1.5
When I use download manager to apply updates I get this message in the console box:

downloading Interface_Adminhtml_Default-1.1.3.tgz ...
Starting to download Interface_Adminhtml_Default-1.1.3.tgz (1,196,337 bytes)
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ...
done1,196,337 bytes
downloading Interface_Frontend_Default
-1.1.3.tgz ...
Starting to download Interface_Frontend_Default-1.1.3.tgz (1,065,433 bytes)
...
done1,065,433 bytes
downloading Lib_Varien
-1.1.2.tgz ...
Starting to download Lib_Varien-1.1.2.tgz (98,480 bytes)
...
done98,480 bytes
downloading Mage_All_Latest
-1.1.5.tgz ...
Starting to download Mage_All_Latest-1.1.5.tgz (1,007 bytes)
...
done1,007 bytes
downloading Mage_Core_Adminhtml
-1.1.5.tgz ...
Starting to download Mage_Core_Adminhtml-1.1.5.tgz (365,272 bytes)
...
done365,272 bytes
downloading Mage_Core_Modules
-1.1.5.tgz ...
Starting to download Mage_Core_Modules-1.1.5.tgz (1,272,815 bytes)
...
done1,272,815 bytes
upgrade ok
channel://connect.magentocommerce.com/core/Lib_Varien-1.1.2
upgrade okchannel://connect.magentocommerce.com/core/Mage_Core_Modules-1.1.5
upgrade okchannel://connect.magentocommerce.com/core/Interface_Frontend_Default-1.1.3
upgrade okchannel://connect.magentocommerce.com/core/Mage_Core_Adminhtml-1.1.5
upgrade okchannel://connect.magentocommerce.com/core/Interface_Adminhtml_Default-1.1.3
upgrade okchannel://connect.magentocommerce.com/core/Mage_All_Latest-1.1.5

But yet nothing gets upgraded, refresh the page and nothing is updated.

So I went to the magento root folder in the command line and typed “./pear upgrade-all” as root

root@ubuntu:/var/www/magento# ./pear upgrade-all
Will upgrade channel://connect.magentocommerce.com/core/mage_core_adminhtml
Will upgrade channel://connect.magentocommerce.com/core/mage_core_modules
Will upgrade channel://connect.magentocommerce.com/core/mage_all_latest
Will upgrade channel://connect.magentocommerce.com/core/interface_frontend_default
Will upgrade channel://connect.magentocommerce.com/core/lib_varien
Will upgrade channel://connect.magentocommerce.com/core/interface_adminhtml_default
magento-core/Lib_Varien requires PHP extension "mcrypt"
magento-core/Mage_Core_Modules requires package "magento-core/Lib_Varien" (version >= 1.1.2version <= 1.2excluded versions1.2), installed version is 1.1.1
magento
-core/Mage_Core_Adminhtml requires package "magento-core/Mage_Core_Modules" (version >= 1.1.5version <= 1.1.5), installed version is 1.1.4
magento
-core/Mage_All_Latest requires package "magento-core/Mage_Core_Modules" (version >= 1.1.5version <= 1.2excluded versions1.2), installed version is 1.1.4
magento
-core/Mage_All_Latest requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.1.5version <= 1.2excluded versions1.2), installed version is 1.1.4
magento
-core/Interface_Frontend_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.1.5version <= 1.2excluded versions1.2), installed version is 1.1.4
magento
-core/Interface_Adminhtml_Default requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.1.5version <= 1.2excluded versions1.2), installed version is 1.1.4
No valid packages found
upgrade
-all failed

I know the mcrypt extension is enabled.
magento-check.php and <?php phpinfo(); ?> confirms it

CongratulationsYour server meets the requirements for Magento.
You have PHP 5.2.0 (or greater)
Safe Mode is off
You have MySQL 4.1.20 
(or greater)
You have the curl extension
You have the dom extension
You have the gd extension
You have the hash extension
You have the iconv extension
You have the mcrypt extension
You have the pcre extension
You have the pdo extension
You have the pdo_mysql extension
You have the simplexml extension

UPDATE:
Found the problem as I was writing this topic.
File permission issue, all I did is # chmod -R 777 /magento/downloader/pearlib/php/
Loged back into Download Manager and upgraded successfully
Figured I post it anyway in-case someone has the same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
webluxor.com
Jr. Member
 
Total Posts:  2
Joined:  2009-03-03
 

realy upgrade ... smile very interesting but i dont understand anything..

Webluxor.com web luxor (860)-865-0246

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top