Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Google Chrome support
 
ylibrach
Sr. Member
 
Total Posts:  78
Joined:  2008-07-06
 

I noticed that in v1.1.5 there are some parts of the backend which are broken in Google Chrome. These same parts were working fine in v1.1.4. I asked in the upgrade forum and the response from a team member was that there is currently no support for Chrome.

That’s fine, but Chrome is a significant browser which a lot of people do use. Are there any plans in the works to officially support this browser in the future?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

I dunno - Google Chrome is clearly stated as ‘BETA’ and I would think that for software to be compatible with new, open source, beta web browsers is just unrealistic expectations.  Also, since the backend seems to work in all the major browsers, perhaps it’s Google Chrome that’s bugged?

Just a thought.

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Mentor
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

Isn’t Chrome using WebKit, just like Safari? Test it in Safari and if the same issue is there then it’s not just Chrome but all WebKit based browsers. FireFox etc. run on the Gecko rendering engine.

I would have liked Magento to be on YUI so all browsers are supported anyway.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LeeSaferite
Guru
 
Avatar
Total Posts:  322
Joined:  2007-08-31
Lake City, FL
 

It seems like the V8 Javascript engine is where the problems lie.  Prototype does some nasty (IMHO) things with built-in javascript classes (mostly DOM elements) and Chrome is having a few issues with that.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top