Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Erro com PagSeguro no Backend ao gerar uma Compra
 
Sweet Gunner
Jr. Member
 
Avatar
Total Posts:  23
Joined:  2009-02-04
 

Olá,

Desde qdo instalei meu Magento estou com este problema…
Nunca consegui gerar uma compra pelo Backend para clientes e nem recomprar nada pois não consigo puxar o método de pagamento nesta tela… nenhum método na verdade, inclusive PagSeguro e Pagto. Digital que utilizo.

Alguém sabe o que posso fazer pra consertar isso?

Não manjo nada de programação.. :S

Obrigada.

PS: Print da tela em anexo…

Image Attachments
26-3-2010 15-14-12.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Sweet Gunner
Jr. Member
 
Avatar
Total Posts:  23
Joined:  2009-02-04
 

ngm pode ajudar ae? pls?? :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruno Assarisse
Sr. Member
 
Avatar
Total Posts:  119
Joined:  2009-09-13
São Paulo - Brasil
 

Olá, Sweet Gunner!

Por acaso encontrei a solução pra isso. No módulo disponibilizado aqui no Forum, já efetuei a correção, mas se você quiser acertar no que você usa, faça o seguinte:

- Abra o arquivo Standard.php do módulo. Procure pela variável $_canUseInternal e mude ela para true:

protected $_canUseInternal true;

Dependendo de qual módulo você utlize, pode ser que o arquivo que você precisa alterar é o PagSeguro.php.

Qualquer coisa, estamos ae!
Abraço

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sweet Gunner
Jr. Member
 
Avatar
Total Posts:  23
Joined:  2009-02-04
 
Bruno Assarisse - 12 May 2010 06:37 AM

Olá, Sweet Gunner!

Por acaso encontrei a solução pra isso. No módulo disponibilizado aqui no Forum, já efetuei a correção, mas se você quiser acertar no que você usa, faça o seguinte:

- Abra o arquivo Standard.php do módulo. Procure pela variável $_canUseInternal e mude ela para true:

protected $_canUseInternal true;

Dependendo de qual módulo você utlize, pode ser que o arquivo que você precisa alterar é o PagSeguro.php.

Qualquer coisa, estamos ae!
Abraço

Poxa, q legal… FUNCIONOU!! Obrigada mesmo! :D
Por acaso o frete nesta tela de Recomprar aparece normal para você?
Pois a escolha do meu frete PAC nesta tela aparece com a mensagem:
Por favor, corrija o CEP digitado, ele não está correto. (Cod. -18)

No caso o CEP está sim correto e no frontend aparece direitinho… só aí que não…

Segue anexo…

Valeu!

Image Attachments
recomprar.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruno Assarisse
Sr. Member
 
Avatar
Total Posts:  119
Joined:  2009-09-13
São Paulo - Brasil
 

Você usa o módulo do Pedro Teixeira? Eu estou usando ele, e aqui o erro foi outro:

PAC - Houve um erro inesperado, por favor entre em contato. A altura nao pode ser inferior a 2 cm. (Cod. 18)

Sendo que o produto está corretamente configurado, pelo que entendo.
Não é a versão mais nova, pois já saiu a 4.0, mas ainda não a testei.

Será que alguém já detectou estes erros? Ou seria configuração?
Vou dar uma pesquisada.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sweet Gunner
Jr. Member
 
Avatar
Total Posts:  23
Joined:  2009-02-04
 

Sim, uso o módulo dele versão 3.0…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top