Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Getting a black image that says ‘Skin Image’ Mag ver. 1.4.0.1
 
davidgrun
Sr. Member
 
Total Posts:  245
Joined:  2008-07-10
 

When I insert an image in my CMS block though Magento’s new Wysiwyg I get a black image with and it says ‘Skin Image’ on it instead of the image that I am trying to insert. (see attached SS)

And the path to the image is this: http://127.0.0.1:8888/magento14/index.php/admin/cms_wysiwyg/directive/key/2b7ca853474ff992e5db0eda360a5538/___directive/e3ttZWRpYSB1cmw9ImltYWdlbmVzX2dlbmVyYWxlcy9nb29nbGVfbWFwLmpwZyJ9fQ,,/

Than, the image in the frontend is broken.

GOT A CLUE??

Thanks in advance for your help!!

David

Image Attachments
black-skin-url.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Jacek Sompel
Jr. Member
 
Total Posts:  8
Joined:  2009-05-17
Melbourne, Australia
 

David,

Have you worked out on how to fix this issue?
I have the same problem with the black skin image in the back-end WYSIWYG editor but it seems that the url gets translated correctly in the front end.
To me it looks like a bug in Magento WYSIWYG editor and it is very annoying.

Thanks,
Jacek

 
Magento Community Magento Community
Magento Community
Magento Community
 
davidgrun
Sr. Member
 
Total Posts:  245
Joined:  2008-07-10
 

@Jacek

Nope, I don’t know how to fix it. The problem is that the URL is wrong in frontend too.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jacek Sompel
Jr. Member
 
Total Posts:  8
Joined:  2009-05-17
Melbourne, Australia
 

@David

I just pulled down the latest version of Magento using SVN.
It seems that the issue is now resolved and images are now showing correctly in the back-end.
I would suggest backup your existing project and then run:

svn checkout http://svn.magentocommerce.com/source/branches/1.4

Good luck.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jacek Sompel
Jr. Member
 
Total Posts:  8
Joined:  2009-05-17
Melbourne, Australia
 

@David

I am not sure what causes this but I tested it on the clean install of Magento and it works without any problems.
I think it could be well and truly related to some of the extensions that were installed that caused this to stop working.
All I ended up doing on my clients site is downloading the current 1.4.0.1 from Magento downloads and then updated the site.
Providing you have not touched any core files, it should fix your problems with the black \\\\\\\’skin image\\\\\\\’.

Good luck.

 
Magento Community Magento Community
Magento Community
Magento Community
 
clingon
Jr. Member
 
Total Posts:  1
Joined:  2010-04-22
 

in the following file->
app/code/core/Mage/Adminhtml/controllers/Cms/WysiwygController.php

you can check the Exception message, which generates this Image with the line in the “caught” code block->

file_put_contents(’!!!  MODIFY IT !!/app/code/core/Mage/Adminhtml/controllers/Cms/test.txt’, $url.$e->getMessage());

and of course, you have to read the created test.txt.

The black “skin image” message apears, because of the missing url file access.
I had to enable it in php.ini
->
......
allow_url_fopen = On;
allow_url_include = On;
....

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top