Magento Forum

   
Importing Images via CSV file
 
Flaxton
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2010-06-03
Houston
 

Make sure the field has a / before the image name. If your image is called productimage-1234.jpg you need to have /productimage-1234.jpg in the field, not just the image name.

 
Magento Community Magento Community
Magento Community
Magento Community
 
niki street
Jr. Member
 
Total Posts:  23
Joined:  2010-02-07
 

I have.. it still puts a EXCLUDED on the admin??

 
Magento Community Magento Community
Magento Community
Magento Community
 
mptorr
Member
 
Avatar
Total Posts:  62
Joined:  2010-04-06
 

@niki, this change can help you

In “app/code/core/Mage/Catalog/Model/product.php”, on (or near) line 759 change:

public function addImageToMediaGallery($file$mediaAttribute=null$move=false$exclude=true)

to:

public function addImageToMediaGallery($file$mediaAttribute=null$move=false$exclude=false)

Now when you upload new products the exclude box will remain unticked.
Try this with some test products and refresh all cache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
niki street
Jr. Member
 
Total Posts:  23
Joined:  2010-02-07
 

Hia,

Thank you very much, that has taken the EXCLUDE off the Thumbnail image but not the other images?? any ideas?

Niki

 
Magento Community Magento Community
Magento Community
Magento Community
 
Weis
Member
 
Avatar
Total Posts:  44
Joined:  2009-02-27
Kiev, Ukraine
 

There are 2 rules how to import images with products.

1) Place all images into media/import dir
2) In your import file specify image this way: ./path_to_images/image.jpg
Magento will looking for you file at media/import/path_to_images/image.jpg

 
Magento Community Magento Community
Magento Community
Magento Community
 
emmenko
Sr. Member
 
Total Posts:  96
Joined:  2010-10-20
 

Hi everybody

I managed to import the gallery.

I did these STEPS until now, so you can follow what I did and how my import settings are.

Anyway, in the csv file I simply wrote the attributes like in the screenshot

As you can see, the picture I want to show, I write it in the fields thumbnail, small_image, image while the other images that I want in to show only in the gallery, I write them in the gallery field as /name.jpg,/name.jpg
There aren’t space between the image’s name and the comma.

I still have one little problem...everytime I do an import, the images aren’t rewrited but there are copies of the images. So if I load the first time 3 images, the second time I import I will have 6 images, the third 9 images and so on.
Same issue with the dropdown “super product attributes” that is repeated every import.

I hope someone can give me a solution.

Bye

Nicola

Image Attachments
screen_gallery.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
emmenko
Sr. Member
 
Total Posts:  96
Joined:  2010-10-20
 

I fixed the problem with the duplicate images every time I do an import.

Read THIS (post #21)

Hope that can help someone ^^

 
Magento Community Magento Community
Magento Community
Magento Community
 
FGP
Jr. Member
 
Total Posts:  8
Joined:  2009-12-14
 

I had everything working but then had the dup problems when I deleted all products then try and re upload only the gallery images would upload.  The “thumbnail, small_image, image” are not updating any thoughts?

Thanks,

Adam

 
Magento Community Magento Community
Magento Community
Magento Community
 
emmenko
Sr. Member
 
Total Posts:  96
Joined:  2010-10-20
 
FGP - 15 November 2010 12:31 PM

I had everything working but then had the dup problems when I deleted all products then try and re upload only the gallery images would upload.  The “thumbnail, small_image, image” are not updating any thoughts?

Thanks,

Adam

Have you written them in the right format?

/name_of_image.jpg

Also, are the images in the folder /media/import/ ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
FGP
Jr. Member
 
Total Posts:  8
Joined:  2009-12-14
 

Yes they are in the folder and in the correct format:

thumbnail small_image image
/DSF25-50-3_1.jpg /DSF25-50-3_1.jpg /DSF25-50-3_1.jpg
/DSF25-50TC-3_1.jpg /DSF25-50TC-3_1.jpg /DSF25-50TC-3_1.jpg

 
Magento Community Magento Community
Magento Community
Magento Community
 
cj68142
Jr. Member
 
Total Posts:  6
Joined:  2009-03-18
 

I don’t have the directory /media/import on my system (1.4.1.1).  Do I simply create the directory or does the fact that I don’t have the directory mean I’m missing something (like a plugin)?  If I create it can I use the default Import All Products or do I have to set up a new import profile and somehow map the location of /media/import?

Thanks, any explanation would be helpful.

 
Magento Community Magento Community
Magento Community
Magento Community
 
_bullseye_
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-04-21
 

the /media/import folder should be there with your default installation (i believe).

If not, just make one.  No plugin needed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wychee
Jr. Member
 
Total Posts:  4
Joined:  2011-08-16
 

Hi

I am new to Magento, and just had the latest Magento version 1.6 installed.

I am trying to import 700 products with images.

Problem was, after running System -> Import -> Products, the import seemed successful (with message \\\"Import successfully done..\\” appeared), but I only got the products WITHOUT the image.

What I did was:

1. In my import csv file, under \’image\’ column, I put my .jpg filename in this format:
E.g.  /abc.jpg

2. ’media_gallery\’ column is compulsory during import, I am not sure what to input, I put in this value inner

3. Lastly I uploaded the image file from my PC into /media/import before running the import process.

However, the image did not appear after the import is completed.

Did anyone encounter this problem? What did I do wrong here?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wychee
Jr. Member
 
Total Posts:  4
Joined:  2011-08-16
 

Hi

I am new to Magento, and just had the latest Magento version 1.6 installed.

I am trying to import 700 products with images.

Problem was, after running System -> Import -> Products, the import seemed successful (with message \\\"Import successfully done..\\” appeared), but I only got the products WITHOUT the image.

What I did was:

1. In my import csv file, under \’image\’ column, I put my .jpg filename in this format:
E.g.  /abc.jpg

2. ’media_gallery\’ column is compulsory during import, I am not sure what to input, I put in this value inner

3. Lastly I uploaded the image file from my PC into /media/import before running the import process.

However, the image did not appear after the import is completed.

Did anyone encounter this problem? What did I do wrong here?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
amit803
Jr. Member
 
Total Posts:  8
Joined:  2011-09-29
 

Thanks for all the help guys.
Very helpful

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top