Magento Forum

   
Cron broken after upgrade
 
Gabriel Queiroz
Sr. Member
 
Total Posts:  135
Joined:  2008-05-28
Brasília, Brazil
 

Hi,

Am I the only one getting this error on the cron job after upgrading to 1.4?

Warningapc_sma_info(): No APC SMA info available.  Perhaps APC is disabled via apc.enabled?

Apc is enabled (tested it through extension_loaded just before the apc_sma_info() call on the core cache class code.

Cheers,

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabriel Queiroz
Sr. Member
 
Total Posts:  135
Joined:  2008-05-28
Brasília, Brazil
 

Tested it in 2 servers, both have this error, only on the cron job. Disabling apc on local.xml obviously fix it…

Strange stuff…

 
Magento Community Magento Community
Magento Community
Magento Community
 
ssag
Jr. Member
 
Total Posts:  1
Joined:  2010-03-16
 

have you set apc.enable_cli = 1 in your php.ini?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabriel Queiroz
Sr. Member
 
Total Posts:  135
Joined:  2008-05-28
Brasília, Brazil
 

Hi saag,

Yes, i have got to fix, but forgot to add the solution here. The problem was me, actually, mistyping apc.enable_cli for apc.enabled_cli. Now everything works as it should.

Thanks,
Gabriel

 
Magento Community Magento Community
Magento Community
Magento Community
 
devopensource
Member
 
Avatar
Total Posts:  42
Joined:  2008-04-23
spain
 
ssag - 26 March 2010 02:40 AM

have you set apc.enable_cli = 1 in your php.ini?

yes this solved. thx

 
Magento Community Magento Community
Magento Community
Magento Community
 
bkscott
Sr. Member
 
Avatar
Total Posts:  137
Joined:  2009-07-16
Sacramento
 

on my server i tried editing my php.ini file and it didnt fix anything. i had to go into php.d and edit a file called apc.ini. it’s setting was overriding the one i added to php.ini, apparently.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top