Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Abbruch der Installation beim Anlegen der Datenbanktabellen
 
Morjan
Member
 
Avatar
Total Posts:  58
Joined:  2008-11-19
Hamburg Süd
 

Hallo,

bei der Installation (Magento 1.4.0.1, PHP Version 5.2.13) der Datenbanktabellen ( MySQL 5.0.77, Apache/2.2.3 (CentOS) )
kommt folgende Fehlermeldung:

a:5:{i:0;s:227:"Error in file: “/var/www/web1/html/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.19-0.8.20.php” - Strict Notice: Only variables should be passed by reference in /var/www/web1/html/lib/Zend/Db/Select.php on line 246";i:1;s:918:"#0 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(374): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(273): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.8.19’, ‘0.8.26’)
#2 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(217): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.8.19’, ‘0.8.26’)
#3 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(153): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /var/www/web1/html/app/code/core/Mage/Core/Model/App.php(363): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /var/www/web1/html/app/code/core/Mage/Core/Model/App.php(295): Mage_Core_Model_App->_initModules()
#6 /var/www/web1/html/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#7 /var/www/web1/html/index.php(78): Mage::run(’’, ‘store’)
#8 {main}”;s:3:"url”;s:1:"/”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:7:"default";}

Es werden ca. 10 Tabellen angelegt, das war es dann…
... und nix geht mehr :-(
Magento-check sagt das alles ok ist!

Hat jemand eine Idee???
PHP Info kann ich euch zukommen lassen…

Bitte Bitte Hilfe!!!

LG Matthias

 
Magento Community Magento Community
Magento Community
Magento Community
 
Morjan
Member
 
Avatar
Total Posts:  58
Joined:  2008-11-19
Hamburg Süd
 

So, habe sämtliche Dateien vom Server gelöscht Datenbanktabellen gelöscht und die alte Version 1.3.2.4 installiert.
Vorher auch noch im Hauptverzeichnis Ordner tmp und database angelegt.
Alle Schreibrechte gesetzt und dann lief die Installation durch !!!!

ABER: Jetzt komme ich nicht ins Admin !!!

Fehlermeldung:

Strict Notice: Only variables should be passed by reference in /var/www/web1/html/lib/Zend/Db/Select.php on line 216
Trace:
#0 /var/www/web1/html/lib/Zend/Db/Select.php(216): mageCoreErrorHandler(2048, ‘Only variables ...’, ‘/var/www/web1/h...’, 216, Array)
#1 /var/www/web1/html/app/code/core/Mage/Eav/Model/Mysql4/Entity/Attribute/Collection.php(70): Zend_Db_Select->columns(Array)
#2 /var/www/web1/html/app/code/core/Mage/Eav/Model/Config.php(606): Mage_Eav_Model_Mysql4_Entity_Attribute_Collection->useLoadDataFields()
#3 /var/www/web1/html/app/code/core/Mage/Eav/Model/Entity/Collection/Abstract.php(367): Mage_Eav_Model_Config->loadCollectionAttributes(’catalog_product’, Array)
#4 /var/www/web1/html/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Collection.php(319): Mage_Eav_Model_Entity_Collection_Abstract->addAttributeToSelect(Array, false)
#5
.
.
.

usw.

Hat jemand eine Lösung???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Morjan
Member
 
Avatar
Total Posts:  58
Joined:  2008-11-19
Hamburg Süd
 

Habe jetzt die lib/Zend/Db/Select.php on line 216 angepasst:

Alt:

$correlationName = current(array_keys($this->_parts[self::FROM]));

Neu:

$arrayKeys = array_keys($this->_parts[self::FROM]);
$correlationName = current($arrayKeys);

Dann kam ich ins Backend. Nach Update auf 1.4 ging aber wieder garnichts mehr!!!
Soll ich jetzt wieder alles löschen und nochmal neu installieren ???

Fehlermeldung:

a:5:{i:0;s:223:\"Error in file: \"/var/www/web1/html/app/code/core/Mage/Tag/sql/tag_setup/mysql4-upgrade-0.7.3-0.7.4.php\" - Strict Notice: Only variables should be passed by reference in /var/www/web1/html/lib/Zend/Db/Select.php on line 246\";i:1;s:914:\"#0 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(374): Mage::exception(\’Mage_Core\’, \’Error in file: ...\’)
#1 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(273): Mage_Core_Model_Resource_Setup->_modifyResourceDb(\’upgrade\’, \’0.7.3\’, \’0.7.5\’)
#2 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(217): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(\’0.7.3\’, \’0.7.5\’)
#3 /var/www/web1/html/app/code/core/Mage/Core/Model/Resource/Setup.php(153): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /var/www/web1/html/app/code/core/Mage/Core/Model/App.php(363): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /var/www/web1/html/app/code/core/Mage/Core/Model/App.php(295): Mage_Core_Model_App->_initModules()
#6 /var/www/web1/html/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#7 /var/www/web1/html/index.php(78): Mage::run(\’\’, \’store\’)
#8 {main}\”;s:3:\"url\”;s:11:\"/index.php/\”;s:11:\"script_name\”;s:10:\"/index.php\”;s:4:\"skin\”;s:7:\"default\";}

Hat jemand einen Tipp???

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top