Magento Forum

can’t change markup - serious newbie question
 
jenna
Jr. Member
 
Total Posts:  5
Joined:  2008-09-11
Athens, Georgia, USA
 

Hi all! Magento looks like a great system and I’m excited to learn how to theme it. Unfortunately, I feel like I am missing something.

You can see my first attempt at a theme in progress here: http://64.27.23.102/

For this go round I’m just making changes to the demo store theme, not trying to build one from scratch. I’ve read the designer’s guide and think I have a handle on the basics. I’ve disabled the cache, enabled template path hints. I’ve been able to make changes to the CSS and images, but I can’t change any of the markup. I’m still getting a handle on the XML things, but the first thing I’m trying to do it something very basic: on the search box at the top or the page, change the image submit button to a regular submit button.

Using template path hints, I determined the file I needed to change is frontend/default/green_theme/template/catalogsearch/form.mini.phtml
I downloaded it, made my change to the HTML, and uploaded the edited file—but there was no change on the site itself. Is there some additional file I’m supposed to edit in this instance? Or some button I’m supposed to hit in /admin (besides disable the cache, which I have done)?

I have read lots of the material on the website and still haven’t got a clue where I might be going astray, so I am hoping someone with more experience can point me in the right direction. This is all still quite new and pretty confusing. Thank you in advance for any assistance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nikefido
Guru
 
Avatar
Total Posts:  481
Joined:  2008-07-11
New Haven, CT
 

That looks like the right file. You’re editing the right part, right? If you view source, it’s this area:

<fieldset>
    <
legend>Search Site</legend>
    <
div class="mini-search">
        <
input id="search" type="text" class="input-text" name="q" value="" />
        <
input type="image" src="http://64.27.23.102/skin/frontend/default/green_theme/images/btn_mini_search.gif" alt="Search" />
        <
div id="search_autocomplete" class="search-autocomplete"></div>
        <
script type="text/javascript">
            var 
searchForm = new Varien.searchForm('search_mini_form''search''Search entire store here...');
            
searchForm.initAutocomplete('http://64.27.23.102/catalogsearch/ajax/suggest/''search_autocomplete');
        
</script>
    
</div>

    </
fieldset>

The button is this line:

<input type="image" src="http://64.27.23.102/skin/frontend/default/green_theme/images/btn_mini_search.gif" alt="Search" />

(This is not from form.mini.phtml but me viewing source - just trying to help you match up what your editing with what’s getting displayed)

 
Magento Community Magento Community
Magento Community
Magento Community
 
jenna
Jr. Member
 
Total Posts:  5
Joined:  2008-09-11
Athens, Georgia, USA
 

I double checked, and that is definitely the line I am editing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jenna
Jr. Member
 
Total Posts:  5
Joined:  2008-09-11
Athens, Georgia, USA
 

I should have double checked my paths as well. Instead of uploading to
frontend/default/green_theme/template/catalogsearch/form.mini.phtml

I was uploading to
frontend/green_theme/template/catalogsearch/form.mini.phtml

Being new at this, I got lost in the vast byzantine layers of template folders. Thanks for checking out my question, all the same. smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top