Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Es werden keine Emails von Magento verschickt
 
Blauz
Jr. Member
 
Total Posts:  4
Joined:  2008-09-12
 

Was mache ich falsch?

Wenn ich als Kunde ein Produkt bestelle läuft alles glatt, bis auf die
Tatsache, dass ich keine Mail bekomme.
Der Admin bekommt übrigens auch keine.

Dabei habe ich im Backend alle notwenigen Einstellungen vorgenommen…

*verzweifel*

Danke für Eure Hilfe!
Blauz

 
Magento Community Magento Community
Magento Community
Magento Community
 
kulimuli
Sr. Member
 
Total Posts:  151
Joined:  2008-03-31
Linz, Oberösterreich
 

Hi,

Windows oder Unix.

Bei Windows folgende Konfig beachten http://ShopUrl/index.php/admin/admin/system_config/edit/section/system/
Bei Linux muss lokal ein Mailserver laufen.

Wenn Du Zugriff auf die SMTP Logs hast, schau ob die E-Mails ev. geblockt werden etc.

LG
kulimuli

 
Magento Community Magento Community
Magento Community
Magento Community
 
Blauz
Jr. Member
 
Total Posts:  4
Joined:  2008-09-12
 

Ist das richtig?

host: localhost (hab auch mail.<domain> probiert)
port: 25

Hab wirklich alle Einstellungen überprüft.
So langsam krieg’ ich ne Kriese…

 
Magento Community Magento Community
Magento Community
Magento Community
 
kulimuli
Sr. Member
 
Total Posts:  151
Joined:  2008-03-31
Linz, Oberösterreich
 

Hi,

arbeitest Du mit Windows? -> da ist mir ein Bug bekannt....

muss jetzt aber schnell weg, falls Du mit Windows arbeitst such im Forum nach Bug SMTP, falls Du nichts findest poste noch mal!

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Hi,

ich habe das selbe Problem! Ich habe meinen Linux-Server bei Hosteurope. Bei den SMTP Einstellungen steht ja Windowsserver. Ich kann mir nicht vorstellen das Magento nur auf Windowsserver läuft?

Kann mir bzw. Blauz jemanden helfen???

Bitte, Bitte, das Problem hält bei der weiterbearbeitung von Magento auf!

bye

 
Magento Community Magento Community
Magento Community
Magento Community
 
kulimuli
Sr. Member
 
Total Posts:  151
Joined:  2008-03-31
Linz, Oberösterreich
 

Hi,

Magento läuft natürlich unter Linux und das ist sogar die empfohlene Variante…
Auf Linux sollte der E-Mail Versand ohne besonereren Einstellungen gehen…

Oft geht der E-Mail Versand nur wenn die Absenderdomäne/Addresse beim Hoster hinterlegt ist… -> welche Absenderadressen für die E-Mails hast du eingestellt und wo hin versendest Du die E-Mails?
Schaue auch ob die E-Mails vielleicht als Spam erkannt und in den Spamordner verschoben wurden…

LG
kulimuli

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Hi kulimulli,

also ich habe Verschiedene Emails auf meinem Webpack. Für den Magentoshop habe ich die Email addi mit dem Shopnamen hinterlegt und überall eingestellt (). Das Problem ist das keine Emails verschickt werden.

In den Configuration > erweitert > kann man unter den SMTP Einstellungen die Emailfunktion und den Server und Port einstellen.
Was muss man da nun eintragen? ( Postausgangsserver/ Eingangsserver des Webpacks oder etwar etwas anderes)

Die Emails werden an meinen Webmailer des Webpacks gesendet ( Spam ist nix drinn)!

Ich habe keine Ahnung was ich noch machen soll, ich hätte nicht gedacht das solche Probleme gibt bei der Installation? Ich kann mir nicht vorstellen das das auch ein großes Problem sein sollte!

Ich habe mich auch mit meinem Webhoster auseinander gesetzt und er teilte mir nur mit, dass Sie sich mit dieser Software nicht auskennen und ich mich an Magento wenden sollte!

Sie haben mir auch gesagt, dass ich bei meinem Webpack über kein mod rewrite verfüge, dass müsste ich extra buchen?

Naja, ich hoffe du kannst mir irgendwie weiterhelfen!

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Ach ja bei deiner URl (http://shopurl/index.php/admin/admin/system_config/edit/section/system/) komme ich auf 404 Fehlerseite raus?

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Man kann zusätzlich noch HTTPS Einstellungen vornehmen!

Auf was sollte ich es stellen?

Dank dir kulimuli?

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Hi, danke an alle die geholfen haben!
Aber es war ein Problem der Orientierung. Bei Hosteurope wurde der Hinweis ziemlich versteckt so das man wirklich nicht im entferntesten darauf kommen konnte, aber egal alles ist in Ordnung.

Bis dahin…

 
Magento Community Magento Community
Magento Community
Magento Community
 
gentlesea
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2008-03-14
Siegen, Germany
 

Was ist mit “Problem der Orientierung gemeint”? Ich bin auch bei Hosteurope und habe eine Magento-Installation am Laufen, von der keine E-Mails verschickt werden. Was musstest Du unternehmen, damit es funktioniert? Sind noch Einstellungen im KIS nötig?

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Da muss ich erstmal Nachschauen....

 
Magento Community Magento Community
Magento Community
Magento Community
 
woody209
Jr. Member
 
Total Posts:  21
Joined:  2008-09-13
 

Hi,

ich konnte das Problem lösen!
Es lag nur an einem falschen Eintrag!

- bei Hosteurope im KIS einlogen
- Hilfe & Support > Webhosting > Webpack > Skripte > Pfadangaben

und dort bekommst du unter Sendmail den folgenden Pfad:

/usr/sbin/sendmail

Diesen Pfad bei SMTP Einstellungen einfügen und den Port so belassen. (25)

Du kannst Ihn auch direkt raus kopieren, ich weiss aber nicht ob dieser bei jedem gleich ist.
Zur Sicherheit solltest du lieber den Weg oben gehen.

Was man aber als aller erstes machen sollte! Eine Email als Standard festlegen!

Ps: ...gib mal bescheid, ob es bei dir funktioniert!!!

ich hoffe ich konnte helfen....

 
Magento Community Magento Community
Magento Community
Magento Community
 
gentlesea
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2008-03-14
Siegen, Germany
 

Danke an woody für den hilfreichen Post. In der Tat musste im KIS von Hosteurope erst unter:

Skripte - Standard-E-Mail-Adresse - Absender-E-Mail-Adresse

eine E-Mail-Adresse ausgewählt werden, die als Absenderadresse fungiert. Danach funktioniert das Senden einwandfrei. Es muss auch nichts bei den SMTP-Einstellungen geändert werden. Bei Bedarf also wieder localhost, 25 eintragen.

Viele Grüße

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top