Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Setting shipping estimate
 
seldon
Sr. Member
 
Total Posts:  92
Joined:  2007-11-08
 

Hi,

In the backend i changed the shipping location of my company to Netherlands, Utrecht, 3584DZ. However, when i then try to order products using the UPS shipping method, the ups api returns that it needs 5 digits in my postalcode. This however seems to indicate that it still expects a US postalcode. Is this a bug/problem with UPS or is something else going on?

Thnx,

Seldon

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

We will look into this issue.

Thanks for reporting this.

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
seldon
Sr. Member
 
Total Posts:  92
Joined:  2007-11-08
 

Please let me know if you have a solution. Thnx!

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

So far what we have found after talking to UPS is that the UPS CGI has a limit of 5 characters for zip code. The UPS XML module should support international zip codes.

This is what we found out form contacting UPS. Please let me know if you have different information.

Thanks

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
seldon
Sr. Member
 
Total Posts:  92
Joined:  2007-11-08
 

Yes it seems to work when i use the XML version. However, an important detail is that you have hardcoded the weight measure in the XML request (you set it to LBS). Ups however does not accept that measure for european contrountries (at least not for the netherlands). I thus would advise/request that you let the user set the weight measure in the admin backend (or make sure that it is correctly coupled to the shipping country of origin). I have now mannually changed the code and replaced LBS with KGS. Then it works !

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top