Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Please help, 1.1.4 unable to generate sitemap
 
iMaster
Member
 
Avatar
Total Posts:  37
Joined:  2008-06-25
 

Hello,
While using 1.1.3 I was able to generate sitemap.xml using “Simple Helix” post:
#1
admin> configuration>google sitmap
Then generated settings > enabled
#2
Catalogue>googlesitemap>add site map
Then File name: sitemap.xml
path:sitemap
storeview: English
#3
The most important part which most people forget:
To generate sitemap with id 1:
Point your browser to http://www.yourshop.com/admin/sitemap/generate/sitemap_id/1
where id is the id number you’ve gotten when you added the site map in step #2

Now even when I follow those steps the sitemap will not generate. I have double checked that the sitemap directory is has 777 rights and even tried creating another directory “newsitemap” and trying to generate a sitemap using the above steps as a guideline.
This issue is driving me crazy, any ideas how to fix it?
Thanks
iMaster

 
Magento Community Magento Community
Magento Community
Magento Community
 
iMaster
Member
 
Avatar
Total Posts:  37
Joined:  2008-06-25
 

I solved the problem I was having thanks to this post “http://inchoo.net/ecommerce/magento/manual-creation-of-google-sitemap-in-magento/”.

I tried using:
http://www.yourstore.com/index.php/admin/sitemap/generate/sitemap_id/[ID of Sitemap from step 1]

and that seems to work.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Oldgamer
Sr. Member
 
Avatar
Total Posts:  142
Joined:  2008-09-12
 

Thanks for posting,
I had a problem when I created folder “export”, despite I made permission 777.
After I created folder “sitemap”, same as in example it was fine. This is very strange, looks like hard coding to me.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top