Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

errore ]SQLSTATE[42000]
 
peppe2
Sr. Member
 
Total Posts:  86
Joined:  2008-08-28
Roma
 

Vers. Magento 1.3.2.3

1) Ho esportato e reimportato tutti i prodotti da sistema>importa/esporta in formato excell
2) Ho provato a creare un prodotto duplicandone un’altro e mettendo nuovo sku etc.
3) mi è comparso l’avviso di quest’errore:

SQLSTATE[42000]Syntax error or access violation1064 You have an error in your SQL syntaxcheck the manual that corresponds to your MySQL server version for the right syntax to use near '))' at line 1

Direi che le conseguenze più gravi sono che non riesco più ad aggiornare le categorie includendo i nuovi prodotti che creo

a) quando seleziono i prodotti da includere dalla categoria la pagina non si aggiorna e i prodotti non vengono inclusi
b) Quando entro nel prodotto per provare ad attribuire il prodotto alla categoria, la finestra della categoria neanche si apre
c) Ho provato a fare il check direttamente sulle tabelle da phpmyadmin ma non trovo nessun errore… Qualcuno mi sa aiutare?
grazie

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexbn
Sr. Member
 
Avatar
Total Posts:  167
Joined:  2009-04-22
Milano
 

Sul forum ho trovato qualcuno con un problema simile al tuo… la causa sembra questa estensione:

http://www.magentocommerce.com/extension/671/featured-products-slideshow

Per caso l\’hai messa anche tu???

Ale

 
Magento Community Magento Community
Magento Community
Magento Community
 
peppe2
Sr. Member
 
Total Posts:  86
Joined:  2008-08-28
Roma
 

Ciao ale,
non, non ho quella estensione, se mi dici dove hai trovato l’argomento cerco di capire se il problema potrebbe essere similare, anche se l’idea che mi sono fatto è che qualcosa non è andato a buon fine con l’esportazione e l’importazione dei file del catalogo. Tra l’altro l’importazione mi aveva dato dei problemi con un messaggio di errore simile, che purtroppo non mi sono appuntato. Poi mi sono reso conto che prima di esportare/importare i prodotti dovevo rimettere il back-end in inglese e tutto procedeva liscio. Probabilmente nel primo tentativo qualche record è passato nel data-base con quest’errore, ce poi è rimasto lì e continua a darmi problemi.
Tra i vari tentativi ho cercato di fare il check alle tabelle in phpmyadmin, ma non trovo errori. Poi può darsi che mi sbaglio…
Grazie del consiglio comunque.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top