Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Delete Category doesn’t work ? 
 
Capitaine Commerce
Member
 
Avatar
Total Posts:  68
Joined:  2007-09-01
Lille, France
 

Before I report it as a bug, I want to know the strange phenomenon I’ve found on Magento is not an effect of my imagination.

It seems that categories can not be deleted in the database when you use the category panel in Magento’s back office. Surely you can click on the button “delete category” when a category is selected and it will disappear from the screen, but not from the database.
Is it a bug or is this voluntary ???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Capitaine Commerce
Member
 
Avatar
Total Posts:  68
Joined:  2007-09-01
Lille, France
 

Ok, I give you my own answer for this one.

Deleting category dosn’t work if innodb isn’t activated in mysql.
To use innodb in mysql, find the my.cnf file in your mysql installation and change the code for everything that’s related to innodb.
Here is an example of what your innodb configuration should look like :

#skip-innodb 
# Uncomment the following if you are using InnoDB tables 
innodb_data_home_dir C:/xampp/mysql/data/
innodb_data_file_path ibdata1:10M:autoextend 
innodb_log_group_home_dir 
C:/xampp/mysql/data/
innodb_log_arch_dir C:/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 % 
# of RAM but beware of setting memory usage too high 
set-variable innodb_buffer_pool_size=16M 
set
-variable innodb_additional_mem_pool_size=2M 
# Set .._log_file_size to 25 % of buffer pool size 
set-variable innodb_log_file_size=5M 
set
-variable innodb_log_buffer_size=8M 
innodb_flush_log_at_trx_commit
=
set
-variable innodb_lock_wait_timeout=50

When you’re done, don’t forget to restart mysql

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top