Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Add to cart button disappeared on Product pages
 
dreamleaf
Jr. Member
 
Total Posts:  3
Joined:  2008-07-04
 

Hi everyone, thanks in advance for all the help you’ve given me while I’ve been lurking!

Yesterday, I must have done something that has stopped the add to cart and product descriptions showing on the product pages.

The “add” buttons still work if you are in category view, but just won’t appear on the product pages.

I’m running the latest release (1.1.4) and have even tried installing all fresh files in the apps folder in case I mixed it with a previous version.

I thought I was very near to being finished.... grateful for some help!! Very grateful!

If you want to see it in action it’s at www.dreamleaf.co.uk/shop

Thanks again

Nik

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Moderator
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

Run a diff on it (I use Beyond Compare to remedy cock-ups like that) and your latest working backup to see if anything in the files changed. If not, you’ll have to check your settings

 
Magento Community Magento Community
Magento Community
Magento Community
 
dreamleaf
Jr. Member
 
Total Posts:  3
Joined:  2008-07-04
 

The weird thing is the only template I had touched is the checkout, to remove the shipping estimate and tax bit.

Yesterday, and looking back it may be something to do with this.... I created a test customer and a customer group to allow free product ordering… ie.  regardless of price they get 100% discount.

It may have been around this time that it went screwy. However, deleting both customer and group doesn’t seem to make a difference.

In case my working copy was wrong, I over-wrote that with the most current release, which to me should have just returned the store to it’s normal templates… but alas, not.

I’ve checked all the product settings and they are allowable in catalog and search.  The puzzling thing for me is that the add to cart is showing and working on the category and front pages, but not on actual product listings....

Can you think of any other way, apart from a full reinstall, and then using an export of the database?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dreamleaf
Jr. Member
 
Total Posts:  3
Joined:  2008-07-04
 

Solved, I borked it, so I reinstalled it.

Tip for anyone else who does the same muppet-like thing i did, if you’re happy with the database, just use the old one for the new install!

 
Magento Community Magento Community
Magento Community
Magento Community
 
GreyWolf
Member
 
Total Posts:  46
Joined:  2008-07-31
 

Well the buy buttons will be disappearing too in 1.1.7. Deleted a couple of items that were discontinued on one of the category pages. Click on any buy button and now all buy buttons say the following:

Fatal error: Call to a member function getItemsCollection() on a non-object in /home/sitename/domain.com/html/app/code/core/Mage/Sales/Model/Quote/Address.php on line 197

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top