Magento Forum

   
Everything Works, except Magento Connect
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 

Hi all
I’ve installed my store and all is working fine. But when I try to use Connect Manager by entering the extension key, hitting install I get a screen saying downloads are happening but it just stays these.

Searched the forums, tried everything, used SSH to set all sorts of folder and file permissions, cleared caches, re-installed
When trying to run PEAR commands, I get PERMISSION DENIED ERRORS. Contacted hosting company. They confirm PEAR is 100% and I don’t nee to run these commands from the command line

Changed folders, no luck. BUT here is the confusing part. When I set preferred state to ALPHA or BETA, I can download and install connect manager update, some old themes

All I want is to download and install osCommesrce migration tools, modern theme, and magento 1.1.4

Please help, thanks:-/

 
Magento Community Magento Community
Magento Community
Magento Community
 
harry12bar
Sr. Member
 
Avatar
Total Posts:  168
Joined:  2008-01-07
 

Hi, Make sure Magento Connect folders are 777 - did you change server? Permissions tend to catch people out. If you changed server let me know I or someone else can help dig you out.

Good luck

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 
harry12bar - 08 September 2008 11:17 PM

Hi, Make sure Magento Connect folders are 777 - did you change server? Permissions tend to catch people out. If you changed server let me know I or someone else can help dig you out.

Good luck

Hi
Have been doing the following
1. used ssh to set folder permissions
2. I use the same login account for admin, mag connecct and ftp

By the way, are we talking about the same folder, I’m setting permissions on the “downloader” folder and sub folders using the following commands

find downloader -type d -exec chmod 777 {} \;

 
Magento Community Magento Community
Magento Community
Magento Community
 
harry12bar
Sr. Member
 
Avatar
Total Posts:  168
Joined:  2008-01-07
 

Yup Downloader file is what i mean .
Shot in the dark here:
downloader/pearlib/pear.ini back up pear.ini (change the name to pearold) refreshed cache ... Really a long shot.

To be honest It sounds like a permissions problem coupled with ????? sorry . I would manually upload file (Downloader (fresh) and back up old one .. Set permissions . Also is your installation in a subfolder?

Can Anyone else step in and help this guy out.

Check all your permissions. If downloader is letting some in then locate the offending folder (usually out put in downloader as error. You may need to manually set the permissions. ( Happened to me a few times last week)… Dont give up your close. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 
harry12bar - 09 September 2008 04:50 AM

Yup Downloader file is what i mean .
Shot in the dark here:
downloader/pearlib/pear.ini back up pear.ini (change the name to pearold) refreshed cache ... Really a long shot.

To be honest It sounds like a permissions problem coupled with ????? sorry . I would manually upload file (Downloader (fresh) and back up old one .. Set permissions . Also is your installation in a subfolder?

Can Anyone else step in and help this guy out.
Good Luck

Hi harry12bar
I’ve followed the PEAR.INI advice previously, no luck, cleaned out cache no luck, set all the permissions for everything to 777 briefly, no luck. The installation is under the root folder masked as public_html

Like I said, the shop actually works 99% (except for the add to basket problem). Its just this one issue. Just don’t want to loose the oscommerce DB with orders and customers.

But thanks for the help, have deleted the entire store, will start from scratch...AGAIN! and let ya’ll know how it went
Tx

 
Magento Community Magento Community
Magento Community
Magento Community
 
harry12bar
Sr. Member
 
Avatar
Total Posts:  168
Joined:  2008-01-07
 

Hi, Befor you do , I had a similar problem when I set up with my host...everything worked but connect. . never got a clear answer but hoist insisted on putting shop in subfolder (catalog or whatever you want) and giving subfolder 777. It worked then. ...Just in case it comes up again.

Good luck

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 
harry12bar - 09 September 2008 05:09 AM

Hi, Befor you do , I had a similar problem when I set up with my host...everything worked but connect. . never got a clear answer but hoist insisted on putting shop in subfolder (catalog or whatever you want) and giving subfolder 777. It worked then. ...Just in case it comes up again.

Good luck

Thanks. Tried everything you said. Installed shop in “mg” folder, no luck. re-installed again (1.1.3) still problems with magento connect. However, no and before I could successfully install only the magento downloader itself, but only when I set the preferences to “ALPHA”

Will do some more troubleshooting. Will can host to confirm PEAR is working as it should

By the way, is the any other way of installing updates and components

Thankg

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
Ivor J - 14 September 2008 07:07 AM

By the way, is the any other way of installing updates and components

You can run installs/updates from SSH, which you actually should be doing if PHP is installed as an Apache module.

For example, to upgrade Magento, run the following in the directory where Magento is installed:

./pear upgrade-all

Or to install the Modern Theme:

./pear install magento-core/Interface_Frontend_Default_Modern

You can even set the alpha/beta/stable state, like so:

./pear install magento-core/Mage_All_Latest-stable-beta
./pear install magento-core/Mage_All_Latest-stable-stable

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 
Crucial - 15 September 2008 09:15 AM

Ivor J - 14 September 2008 07:07 AM
By the way, is the any other way of installing updates and components

You can run installs/updates from SSH, which you actually should be doing if PHP is installed as an Apache module.

For example, to upgrade Magento, run the following in the directory where Magento is installed:

./pear upgrade-all

Or to install the Modern Theme:

./pear install magento-core/Interface_Frontend_Default_Modern

You can even set the alpha/beta/stable state, like so:

./pear install magento-core/Mage_All_Latest-stable-beta
./pear install magento-core/Mage_All_Latest-stable-stable

Hi
Tried that also, “get a permission denied”. Called host, told me PEAR is okay. Will sort that with them and post back here
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 

More help needed

I’ve basically exhausted efforts with Magento connect. Contacted host. They don’t want to give me ROOT access, obviously, did not ask for it either. They claim the commands listed above require ROOT access.

There must be another way to install updates, surely or does PEAR really require ROOT access.

Any help welcome, this is the only problem I have.

When using magento connect, it starts the download and just hangs there

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
LeonL
Jr. Member
 
Total Posts:  8
Joined:  2008-08-06
Nottinghamshire, UK
 

I also had the same problem of having everything functioning OK except Magento Connect after I had migrated from one server to another.

What finally worked for me was do delete the pear.ini file (I had previouisly tried manually editing it with no success).  Once I deleted it, it auto-generated with the correct values, and away it went.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ivor J
Jr. Member
 
Total Posts:  17
Joined:  2008-08-22
 

Deleted it under the pearlib folder. No luck

This is really weird

Ta

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
Ivor J - 15 September 2008 07:09 PM

Tried that also, “get a permission denied”. Called host, told me PEAR is okay. Will sort that with them and post back here
Thanks

Do this from the root directory where Magento is installed:

chmod o+x pear

...or this:

chmod 777 pear

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top