Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problems after activating cache
 
lipo
Jr. Member
 
Total Posts:  7
Joined:  2007-11-22
 

The install went without a hitch. Then i activated cache and started to obtain occasionally errors. After deactivation I obtain following error (frontend page loads after a pile of error massages, no the admin page though):

Warning: Invalid argument supplied for foreach() in /www/htdocs/w00935c9/magento6137f/lib/Zend/Cache/Backend/File.php on line 460
[0] in Zend_Cache_Backend_File->_unregisterTag("config_global") in /www/htdocs/w00935c9/magento6137f/lib/Zend/Cache/Backend/File.php on line 269
[1] in Zend_Cache_Backend_File->remove("config_global") in /www/htdocs/w00935c9/magento6137f/lib/Zend/Cache/Core.php on line 310
[2] in Zend_Cache_Core->remove("config_global") in /www/htdocs/w00935c9/magento6137f/app/code/core/Mage/Core/Model/Config.php on line 62
[3] in Mage_Core_Model_Config->init(NULL) in /www/htdocs/w00935c9/magento6137f/app/code/core/Mage/Core/Model/App.php on line 126
[4] in Mage_Core_Model_App->init("base", NULL) in /www/htdocs/w00935c9/magento6137f/app/Mage.php on line 359
[5] in Mage::app("base", NULL) in /www/htdocs/w00935c9/magento6137f/app/Mage.php on line 379
[6] in Mage::run("base") in /www/htdocs/w00935c9/magento6137f/index.php on line 28
.....
.....

Karl

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi Karl,

What PHP version do you have ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lipo
Jr. Member
 
Total Posts:  7
Joined:  2007-11-22
 

Hi Michael,

PHP version is 5.2.5.  I think the issue is the same as:

http://www.magentocommerce.com/boards/viewthread/1600

The hoster upgraded yesterday. On Local pc i have no problems. Nothing to do with cache afterall, I think.

Thanks

Karl

 
Magento Community Magento Community
Magento Community
Magento Community
 
lipo
Jr. Member
 
Total Posts:  7
Joined:  2007-11-22
 

Zend Cache Patch in ZF Issue Tracker:

http://framework.zend.com/issues/browse/ZF-2200

grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top