Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

where do my bug reports go ? 
 
notzippy
Member
 
Avatar
Total Posts:  63
Joined:  2008-07-07
 

Hi

How can I search for my “Bug Tracking” issues ? It does not appear to allow you to search by “reported by”, so how can I tell which of my bug’s are being worked on ?

Speaking of bugs here is a fix for Mage_Catalog_Model_Convert_Adapter_Product, The issue is when you import a new product it does not appear in your store. The reason for this is catalog_product_enabled_index and catalog_product_website do not get populated during the import. The fix is to add the following code before the product->save() in the saveRow() function

if (Mage::app()->isSingleStoreMode()) {
            $product
->setWebsiteIds(array(Mage::app()->getStore(true)->getWebsiteId()));
        
}
        
else {
            $product
->setWebsiteIds(array($store->getWebsiteId()));
        
}
        $product
->save();

        return 
true;

and while im at it Mage_Adminhtml_Catalog_ProductController->__initProductSave()

if (Mage::app()->isSingleStoreMode()) {
            $product
->setWebsiteIds(array(Mage::app()->getStore(true)->getId()));
        
}
should be
if (Mage::app()->isSingleStoreMode()) {
            $product
->setWebsiteIds(array(Mage::app()->getStore(true)->getWebsiteId()));
        
}

nz

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top