Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Internal Server Error - help please- php5
 
neuromancer
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2007-11-20
 

Hello,

I’ve been trying to install this for days and have not been able to figure it out, so I am coming to the forums. I have the dreaded internal server error 500, and have not been able to shake it. I have tried changing my .htaccess according to other posts but none of them worked for me. yaarg. I even tried the php4 cgi workaround and that didnt work either. I even tried rebuilding apache and php to see if that was the problem. The weird thing is that in the middle of rebuilding my apache and php I could see the install page, but when apache and php actually finish building I get that server 500 error.
I have a feeling it has something to do with my php 5 configuration for some reason, but I could be wrong.

OS: Linux Redhat
Control Panel: WHM/Cpanel
I am running PHP 5.2.3
mysql 4.1
Zend Engine 2.2
you can check my php configuration here: http://www.neurolinx.net/info.php

I restarted and did a fresh install in the directory
http://neurolinx.net/magento/ according to the SSH instructions.

If anyone can give me an inkling on what might be wrong with this setup I would greatly appreciate it!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Can you rename or remove .htaccess from /magento folder, move info.php into this folder, and try accessing it?

Also paste contents of current .htaccess please.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Though it’s not directly related to the issue you have, but since you are rebuilding php now, you have to include pdo_mysql support in php.

 
Magento Community Magento Community
Magento Community
Magento Community
 
neuromancer
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2007-11-20
 

Heres the .htaccess info (I did not alter it from the install):

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
</IfModule>

DirectoryIndex index.php

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.phpf4d87b

Thanks for all your help. I did rename the .htaccess to .htaccess_BAK and copied the info.php into that directory. http://neurolinx.net/magento/info.php Sure enough the info.php gave the same internal server error 500. Looks like it might be some kind of cgi restriction? However, I’m not aware of what is causing that. Oh and I do have the requirements and pdo_mysql in my build.

On another note, I did another installation under the directory http://www.neurolinx.net/magento_w_php_cgi/ with the php4 work around and it seemed to work with the .htaccess info given in http://www.magentocommerce.com/boards/viewthread/804/.
I still would like to install it without the work around though. Since I am running PHP 5.2.3 and have everything in the sys requirements I was hoping not to go through the php4 work around every time I install this. Any clues on why this may be happening? cheese

By the way Magento Rocks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kathy
Member
 
Avatar
Total Posts:  44
Joined:  2007-11-11
 

Hello neuromancer!

You should check the httpd.conf file for your Apache and edit it to “Allow Override All” in your Directory for Magento.

It works for me.

Cheers,
kathy

 
Magento Community Magento Community
Magento Community
Magento Community
 
neuromancer
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2007-11-20
 

Hey Kathy thanks,

Hi I went to /etc/httpd/conf/httpd.conf and made some changes.
However I’m not exactly sure how to make it specific for my directory.
I tried something like this and received a forbidden error.

<Directory "/home/usr/public_html/magento">
        
AllowOverride All
        Options None
        Order allow
,deny
        Allow from all
    
</Directory>
 
Magento Community Magento Community
Magento Community
Magento Community
 
tijuan
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2007-11-22
Toulouse (France)
 

For people who have an internal error,
make sure first that apache mod_rewrite is simply on

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top