Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 5 of 5
PHP Extension “pdo_mysql” must be loaded
 
jonno1979
Jr. Member
 
Total Posts:  9
Joined:  2009-04-16
 

Hi

I had the same problem, i contacted the host company and they installed it.

worth a try,

 
Magento Community Magento Community
Magento Community
Magento Community
 
Joel Green
Jr. Member
 
Total Posts:  8
Joined:  2008-10-31
 
Sunbreaks - 10 December 2008 01:45 PM


extension=pdo_mysql.so

I had been following this thread and added the other two extension commands previously, which I left in there; but I also added the above, so my php.ini file now has these three lines:

extension=pdo.so
extension=pdo_mysql
extension=pdo_mysql.so


Regards,
Sunbreaks

Thanks, that worked for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
tml2009
Jr. Member
 
Total Posts:  1
Joined:  2009-12-08
 

PHP Extension “pdo_mysql” must be loaded

This is my fist time encounter this error.

After i report to my hosting company above error. they help me to fixed via install the extension.

Now my site is up. http://www.topmarketingleads.com

Highly recommend.
JustHost

thank you very much.

 
Magento Community Magento Community
Magento Community
Magento Community
 
AOhland
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2010-01-19
Florida
 

Hello, world.

Same problem here: I am doing my first Magento installation and “PHP Extension “pdo_mysql” must be loaded”. I’m working the problem and I have put my phpinfo file here:

http://www.hardbluefunk.com/phpinfo.php

help, please? Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ashok G
Jr. Member
 
Total Posts:  1
Joined:  2009-10-05
 
tatt2phelia - 11 August 2008 09:08 AM

You can work around not having pdo_mysqly installed. I had the problem at first and got around it now having a total different problem. But you change the following to get around the pdo_mysql:
app/code/core/Mage/Install/etc/install.xml remove pdo_mysql from the list of requirements, do not just comment it out because under the require tag it will read a comment as a required extension.
app/etc/config.xml change <type>pdo_mysql</type> to <type>mysqli</type>

This worked for me.

I tried it ended me with the following error

Fatal error: Call to undefined method Varien_Db_Adapter_Mysqli::changeColumn() in /home/valuewho/public_html/magento/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.8-0.8.9.php on line 32


Can anybody give me a solution

 
Magento Community Magento Community
Magento Community
Magento Community
 
AcuraNSX
Jr. Member
 
Total Posts:  1
Joined:  2010-01-09
Ipoh, Malaysia
 

Same problem here.. anyone please help..appreciate..

PHP Extension “pdo_mysql” must be loaded!!!!

e.5pwebdesign.com/phpinfo.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
groupv
Jr. Member
 
Total Posts:  1
Joined:  2010-08-15
 
JLHC - 29 May 2009 06:23 PM

@Adorno: From what I see in your phpinfo file the extensions “pdo_mysql” is not available. You should contact your hosting provider to have this compiled.

My host hosting-domains.com is telling me that PDO’s are unreliable:  “PDO’s has been causing MYsql crashes across the Internet. We are waiting fir them to provide a current update to fix these problems.”

Is there any way to work around this?  They seem to not want to install it for me.  I do have PHP Pear Installer on my cPanel - Can I use this to install the PDO?

Thanks in advance for any help,

Ryan

 
Magento Community Magento Community
Magento Community
Magento Community
 
chunware
Jr. Member
 
Total Posts:  2
Joined:  2011-05-22
 

i cant get magneto to run im getting this error

Configuration
PHP extension \\\"pdo_mysql\\\" must be loaded.
PHP extension \\\"mcrypt\\\" must be loaded.
Please set all required settings before clicking Continue

here is my php info http://chunware.com/phpinfo

contact me via

 
Magento Community Magento Community
Magento Community
Magento Community
 
chunware
Jr. Member
 
Total Posts:  2
Joined:  2011-05-22
 

i cant get magneto to run im getting this error

Configuration
PHP extension \\\\\\\"pdo_mysql\\\\\\\" must be loaded.
PHP extension \\\\\\\"mcrypt\\\\\\\" must be loaded.
Please set all required settings before clicking Continue

here is my php info http://chunware.com/phpinfo

contact me via

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

Hello chunware,

You will need to contact your webhost and request the changes to be made. They have PDO explicitly disabled, and mcrypt is not listed in the build options.

 
Magento Community Magento Community
Magento Community
Magento Community
 
asakashyap
Jr. Member
 
Total Posts:  5
Joined:  2010-08-04
 

Just need to write

extension=pdo_mysql.so

instead of <b>extension=pdo_mysql</b>

 
Magento Community Magento Community
Magento Community
Magento Community
 
Janmejay Pati
Jr. Member
 
Total Posts:  2
Joined:  2012-09-26
 

grin Resolved:

Write this to your php.ini

extension=pdo.so
extension=pdo_mysql.so

 
Magento Community Magento Community
Magento Community
Magento Community
 
najha
Jr. Member
 
Total Posts:  1
Joined:  2013-05-09
 

Hi,

I am having the same problem, but I looked for my php.ini and can not find it only php.ini.sample, where I can find it?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Janmejay
Jr. Member
 
Total Posts:  1
Joined:  2009-11-19
 
najha - 23 July 2013 11:32 AM

Hi,

I am having the same problem, but I looked for my php.ini and can not find it only php.ini.sample, where I can find it?

Thanks

remove .sample

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 5 of 5