Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP Extension “pdo_mysql” must be loaded
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

Not sure mate, did you remove the semi-colon and reboot yeh? Did you install your php and apache manually?

I use devside.net’s web developer suite (the free version) ...
http://sourceforge.net/project/showfiles.php?group_id=187164&package;_id=218437

Extremely easy to use, and I have pdo working fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WingJanTam
Jr. Member
 
Total Posts:  1
Joined:  2009-04-09
 

Where can i find my php.ini file? I only see a php.ini.sample file, is that the same?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 
WingJanTam - 19 April 2009 02:09 AM

Where can i find my php.ini file? I only see a php.ini.sample file, is that the same?

You can rename that file to “php.ini”. I believe the codes are already there. If the codes are not there you can add them into that file. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

Some settings may need adjusting. Check that doc_root and include_path relate to real directories

 
Magento Community Magento Community
Magento Community
Magento Community
 
vladmartinez
Jr. Member
 
Total Posts:  1
Joined:  2009-05-28
 

Hello guys :

I’ve just downloaded magento and I found there was a problem during the magento installation : the famous “pdo_mysql has to be loaded”.

I use to have all my website host with HOSTMONSTER.

In order to have pdo_mysql active (which is not active by default in th php.ini) you have to do the following steps :

- connect to your server through an ftp client
- verify you’ve got a php.ini.sample in your http folder
- edit it
- put the following lines at the end of you php.ini.sample :
extension=pdo_mysql.so
extension=pdo.so
extension=pdo_sqlite.so
extension=sqlite.so

- close and register it
- rename php.ini.sample to php.ini

I don’t have invented anything, I just found a great technical support on the HOSTMONSTER chat. The guy was very efficient and It took me 10 minutes to put magento work for a problem which looks like an “year to resolve” problem.

Nevertheless you’ll find the original instructions given by the technician.

I hope it will really help all who have to face that problem....

Cheers !

File Attachments
steps magento.doc  (File Size: 15KB - Downloads: 475)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Adorno
Jr. Member
 
Total Posts:  4
Joined:  2009-05-29
 

Hello everyone
Looks like I am on the same ship.
I am getting the PHP Extension “pdo_mysql” must be loaded error. I tried Vladmartinez fix but it did not work.
Here are the contents of my magento check file:
* You need MySQL 4.1.20 (or greater)
* You are missing the pdo_mysql extension

The following requirements were successfully met:

* You have PHP 5.2.0 (or greater)
* Safe Mode is off
* You have the curl extension
* You have the dom extension
* You have the gd extension
* You have the hash extension
* You have the iconv extension
* You have the mcrypt extension
* You have the pcre extension
* You have the pdo extension
* You have the simplexml extension
My host assured me that they are running MySQL 4.1.25
I wrote and uploaded phpinfo.php to my server at http://www.electronicswarehouse.biz/magento if anyone wants to look at it. Hopefully it’s correct
There originally was no php.ini file so I renamed, edited and uploaded php.ini.sample with all the corrections that vladmartinez suggested but it did not work. I also contacted my hosting provider 3 times and they do not know what pdo_mysql is.
any suggestions as to what I should do? I will only change host as an absolute last remedy as this problem is probably an easy fix.

oops wrong url here is the correct one
http://www.electronicswarehouse.biz/magento/phpinfo.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@Adorno: From what I see in your phpinfo file the extensions “pdo_mysql” is not available. You should contact your hosting provider to have this compiled.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adorno
Jr. Member
 
Total Posts:  4
Joined:  2009-05-29
 

Thats just what I was doing, after being on hold for 32 minutes I hung up and I am now trying e-mail.

I also noticed that once thats done I should restart apache, is that something I can do or do I have to call it in?

Thanks for the info, I had a feeling it was my providers fault.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@Adorno: No restarting Apache will not help if they do not even have the extension compiled. Do let us know what they say about this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adorno
Jr. Member
 
Total Posts:  4
Joined:  2009-05-29
 

Absolutely, as soon as they answer my e-mail, although I don’t expect an answer to my e-mail tonight but i will call them tomorrow. I’ll keep you updated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adorno
Jr. Member
 
Total Posts:  4
Joined:  2009-05-29
 

Got an answer by e-mail, here it is..
Thank you for contacting HughesNet Web Services technical support!

We apologize but it has been determined that we can not enable PDO_MYSQL support. PDO_MYSQL support should be compiled into PHP and as the result the environment will be changed for all users of our platform (shared hosting platform). But we will consider this feature for future releases of PHP. Please feel free contacting us and we will be glad to assist you.
We are available 24 hours a day, 7 days a week for additional assistance, and invite you to contact us if you have any additional concerns.

Regards,

E.S.S.U.
Technical Support Specialist

I don’t know much about website hosting but shared hosting platform???? That doesn’t sound right for something I’m paying for. Anyway it looks like I will be switching web host. First one I’ll check out will be aspiration hosting, thanks for your help JLHC. If you or anybody else reading this have any recommendations feel free to PM me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@Adorno: Yes you should be on a shared hosting platform and most shared hosting provider will not enable an extension just for a user as it may mess up another user’s website, but this is not the case for “pdo_mysql”. Feel free to contact us directly or PM me as we are not able to self-promote in this forum. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sweet Tooth
Sr. Member
 
Avatar
Total Posts:  121
Joined:  2008-02-02
Canada
 

I got dinged hard by this.

Make sure you run your php_info() and take a close look at “Configuration File (php.ini) Path”.  You might be adding the extension=pdo_mysql lines in a php.ini file that’s not even being read!

“Loaded Configuration File “ will confirm which php.ini file it’s reading.

Also, make sure your “extension_dir” within the right php.ini is pointing to the right directory where all your pdo_mysql.so or other .so or .dll files are located.  If you’re not sure, just do a search.

I really hope this information saves someone time.

Cheers,

 
Magento Community Magento Community
Magento Community
Magento Community
 
John7745
Jr. Member
 
Total Posts:  1
Joined:  2009-06-01
 

Important Info for Bluehost users experiencing this issue

I just corrected this issue myself. The people suggesting adding to the php.ini file are correct. But, there is an important step that has not been mentioned to bluehost users which needs to be done after changing the php.ini file (or before):

In your control panel, scroll down to Software / Services and click PHP Config. On the next page, Select the following option:
PHP5 (Single php.ini)
Same as PHP5, but all subdirectories will use ~/public_html/php.ini
Then click the Save Changes button.

Bluehost’s help page illustrating how to properly change the php.ini file can be found here: http://helpdesk.bluehost.com/index.php/kb/article/000445

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fanding
Jr. Member
 
Total Posts:  1
Joined:  2009-04-13
 

Installing PHP Extension “pdo_mysql” run the following if you have SSH access

# sudo pecl install pdo
# sudo pecl install pdo_mysql

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top