Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP Extension “pdo_mysql” must be loaded
 
nvst18
Jr. Member
 
Total Posts:  9
Joined:  2009-02-10
 

can I just get it from PECL and put it on?

 
Magento Community Magento Community
Magento Community
Magento Community
 
nvst18
Jr. Member
 
Total Posts:  9
Joined:  2009-02-10
 

there is an option to give an easy install address and the PHP Panel picks it up and installs it

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

I have no idea mate sorry

 
Magento Community Magento Community
Magento Community
Magento Community
 
nvst18
Jr. Member
 
Total Posts:  9
Joined:  2009-02-10
 

well, i’ll try and if it doesn’t work I’ll talk to the php guy tomorrow and if that doesn’t work then I guess I’ll change hosts.  Does Go Daddy work ok with Magento?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

never used them mate. Ive just gone with http://www.ezpzhosting.co.uk/ not bad, very quick support response aswell

 
Magento Community Magento Community
Magento Community
Magento Community
 
AlfTheCat
Jr. Member
 
Total Posts:  4
Joined:  2009-03-05
 

Hey all,

I hope this thread isn’t exhausted yet but I found the info usefull except my host was right in saying they do not support PDO_mysql and mycript. It just won’t work. Period.

They told me there is a workaround (CGI script) but could not say what exactly.

So I’m stuck at the error message. I’m dying to take magento for a spin and I can’t imagine this problem can’t be overcome. It would be a huge flaw to this system that seems to offer so much....

So… help, anyone?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Marcel van Hemert
Jr. Member
 
Total Posts:  4
Joined:  2009-02-11
 

Same problem here: The pdo_mysql extension is not loaded.
I just called my hosting provider (Strato) and they told me they only offer pdo_mysqlite.
If the pdo_mysql extension is really required I have to switch provider.
So can anybody tell me if there is a workaround or other solution?

I do not want to go to an other provider if it is not really necessarry.
I first want to test connecting magento and joomla. This seams not to work on a localhost (XAMPP).
Only if a good connection can be made I want to switch, but first I need to test.
So please give me a good advice.

Thanks in advance.

Marcel
http://www.oasisimaging.eu

Server: Apache/1.3.37 (Unix)
PHP Version 5.2.8
Mysql version: 5.0.51

 
Magento Community Magento Community
Magento Community
Magento Community
 
AlfTheCat
Jr. Member
 
Total Posts:  4
Joined:  2009-03-05
 

Hey Marcel,

I have looked everywhere but it running magento on a shared host just will not work, period.

You need dedicated hosting. It seems a conscious decision by the magento developpers to work like this, apparently they reason that if you are a serious webshop keeper it shouldn’t be a bother to pay a few hundred bucks a year extra for dedicated hosting. Fair enough but it poses problems for designers/ entities wanting to test before engaging with magento and probably excludes a lot of valuable users from the community.

All the best!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

Hi AlfTheCat

Im not on dedicated hosting, I am using a reseller account from http://www.ezpzhosting.co.uk and it works fine, straight install the extension was already enabled. and that is on shared hosting.

 
Magento Community Magento Community
Magento Community
Magento Community
 
AlfTheCat
Jr. Member
 
Total Posts:  4
Joined:  2009-03-05
 

Hi Chippo,

It’s great to hear some hosting parties do provide the extensions. Perhaps in my region (Netherlands & Belgium) it’s a more common practice not to. Although I must say this and other threads are full of posts regarding shared hosts that won’t even considder supporting the extensions. So if it’s your luck or my bad luck remains a question smile For the Benelux, as far as my information is correct, dedicated hosting is required…

I did encounter a reference to a workaround using CGI but the description was too vague to follow up and I found no reference elsewhere on the Internet. So i’ll keep my subscription to this thread active.... wink

Regards!

 
Magento Community Magento Community
Magento Community
Magento Community
 
citydevi
Jr. Member
 
Total Posts:  3
Joined:  2009-04-09
 

Hi,

For installing the magento in my localhost, i have the following message. How to rectify it? Most forums, it is handled through php.ini. But i don’t understand the path. is it c:/WINNT/php.ini or else php.ini file in magento folder?

o PHP Extension “pdo_mysql” must be loaded
o PHP Extension “mcrypt” must be loaded
o PHP Extension “curl” must be loaded

Kindly advise me to solve this issue. Thanks.

Regards,

Chitra Devi V.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

Hi citydevi

Sometimes it is in your C:/winnt/ or C:/windows/ which ever you have, but sometimes it is actually in the php install directory, for example mine is in C:/www/php/. php.ini should not be in the magento folder

 
Magento Community Magento Community
Magento Community
Magento Community
 
citydevi
Jr. Member
 
Total Posts:  3
Joined:  2009-04-09
 

Hi Chippo,

Thanks for your advice. I use

; extension=pdo.so
; extension=pdo_mysql
; extension=pdo_mysql.so

in php.ini file. But the same error

o PHP Extension “pdo_mysql” must be loaded
o PHP Extension “mcrypt” must be loaded
o PHP Extension “curl” must be loaded

occured. What is tha solution. i use php 5.2.3, and Apache 2.2.3 Kindly advice Me.

Regards,
Chitra Devi V

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chippo
Jr. Member
 
Total Posts:  15
Joined:  2009-01-10
 

Hi citydevi

You must remove the semicolon (;) from the beginning of those lines to enable them.

Oh and you will have to restart your apache or IIS once you have removed the semicolon, as the server needs to be restarted for it to take effect.

Hope that helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
citydevi
Jr. Member
 
Total Posts:  3
Joined:  2009-04-09
 

hi,

I use the following also.

extension=pdo.so
extension=pdo_mysql
extension=pdo_mysql.so

But no use the same issue are there.

o PHP Extension “pdo_mysql” must be loaded
o PHP Extension “mcrypt” must be loaded
o PHP Extension “curl” must be loaded

I didn’t know the problem. Kindly advice me please.

Regards,

Chitra Devi V

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top