Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 5
PHP Extension “pdo_mysql” must be loaded
 
tgne
Jr. Member
 
Total Posts:  2
Joined:  2007-11-19
 

I am using Bluehost.com as my hosting provider.

From my phpinfo() I have PHP 5.2.5 installed.

I am trying to install Magento and i get the following error

PHP Extension “pdo_mysql” must be loaded

I contacted my Hosting provider and they said they installed the extension for me, I tried to run the install again and I still get the same error.  They recommended copying the php.ini file in the install/wizard/config directory, however I can not located this, I’m assuming it’s because of url rewritting.  I did however add the php.ini file to the folder labled Install under /app/code/core/mage/install and this didn’t help locate the extension.  I also added extension=pdo.so
extension=pdo_mysql.so

to my php.ini file as requested by my hosting company.

After hours on the phone and chatting with their tech support I’m still getting the same error that the extension is not loaded.

Any help or ideas would be great.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi tgne,
Can you copy the php.ini file to the magento root directory, create there also a file (e.g. phpinfo.php) with the following content:

<?php phpinfo()?>
and let me know the link to it ?
 
Magento Community Magento Community
Magento Community
Magento Community
 
Snarf
Jr. Member
 
Total Posts:  1
Joined:  2008-04-07
 

I’m having the same problem stated above.  Here is the link to my php info: http://bakerjosh1979.startlogic.com/HTML_AND_PHP.php I’m using startlogic servers.

 
Magento Community Magento Community
Magento Community
Magento Community
 
roadrunner
Jr. Member
 
Total Posts:  16
Joined:  2008-04-04
 

I also cannot get it up on Hostmonster, which is owned by the same folks as Bluehost.  All help will be appreciated, please.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

You’ll need to post the results of your PHP info file. Create a blank file in your root directory and put only the following in it:

<?php phpinfo(); ?>

It would be best to post the link to that in here once you have done so.

 
Magento Community Magento Community
Magento Community
Magento Community
 
havocware
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2008-04-09
Chicago, IL
 

Hi There.  I’m having the same issue installing, using odsol.com as a host.  I was able to add
extension=pdo.so
extension=pdo_mysql

to my php.ini file, but still no luck.

Here’s a link to phpinfo() as running on my sandbox: http://www.havocware.com/phpinfo.php

Thanks
hw

 
Magento Community Magento Community
Magento Community
Magento Community
 
Airforce111
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2008-01-31
 
havocware - 09 April 2008 04:53 PM

Hi There.  I’m having the same issue installing, using odsol.com as a host.  I was able to add
extension=pdo.so
extension=pdo_mysql

to my php.ini file, but still no luck.

Here’s a link to phpinfo() as running on my sandbox: http://www.havocware.com/phpinfo.php

Thanks
hw

You have PDO and pdo_sqlite installed but not pdo_mysql, you need to enable/install pdo_mysql which is a driver for PDO.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tatt2phelia
Jr. Member
 
Total Posts:  2
Joined:  2008-08-04
 

You can work around not having pdo_mysqly installed. I had the problem at first and got around it now having a total different problem. But you change the following to get around the pdo_mysql:
app/code/core/Mage/Install/etc/install.xml remove pdo_mysql from the list of requirements, do not just comment it out because under the require tag it will read a comment as a required extension.
app/etc/config.xml change <type>pdo_mysql</type> to <type>mysqli</type>

This worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
acchile
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-08-18
Itu, SP
 

You can work around not having pdo_mysqly installed. I had the problem at first and got around it now having a total different problem. But you change the following to get around the pdo_mysql:
app/code/core/Mage/Install/etc/install.xml remove pdo_mysql from the list of requirements, do not just comment it out because under the require tag it will read a comment as a required extension.
app/etc/config.xml change <type>pdo_mysql</type> to <type>mysqli</type>

This worked for me.

I tried it and i gone to next step… BUT (ever have a but...) in the “configuration” step, after fill in all informations as database, user, password and click in continue, i received the following:

o pdo_mysql extension is not installed
o Database connection error

Please, some good soul, how can I pass through more this error?

My phpinfo: phpinfo

TKS, regards!

Acchile.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GeraldS
Jr. Member
 
Avatar
Total Posts:  27
Joined:  2008-09-12
Zevenaar
 

Same error over here.
PHP Extension “pdo_mysql” must be loaded
link: http://www.4xlkleding.com/magento/phpinfo.php

Hope someone can help me with this.

gerald @ joynet .nl

 
Magento Community Magento Community
Magento Community
Magento Community
 
benfrain.com
Sr. Member
 
Total Posts:  142
Joined:  2008-08-15
 

I had a similar problem documented here:

http://www.magentocommerce.com/boards/viewthread/17506/

It ended up being the host end and they sorted it - there explanation was ‘mysql server hadn’t been installed due to a failed dependency which I missed’

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 
GeraldS - 18 September 2008 04:14 PM

Same error over here.
PHP Extension “pdo_mysql” must be loaded
link: http://www.4xlkleding.com/magento/phpinfo.php

Hope someone can help me with this.

gerald @ joynet .nl

It seems that your server does not have pdo_mysql loaded. I suggest you to contact your host and see whether they can install it for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bazaartimbuktu
Jr. Member
 
Total Posts:  2
Joined:  2008-09-20
 

am i m issign something.  My provider (startlogic) told me that pdo_mysql can’t be loaded on shared account.  But I can load it if I signup for virtual or dedicated server.  any help would be appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 
bazaartimbuktu - 23 September 2008 07:46 PM

am i m issign something.  My provider (startlogic) told me that pdo_mysql can’t be loaded on shared account.  But I can load it if I signup for virtual or dedicated server.  any help would be appreciated.

What your provider meant is that their server does not have pdo_mysql loaded and are not planning to include it. A virtual or dedicated server will give you more flexibility in terms of this as you are in full control (be sure to confirm that it is a fully managed server).

 
Magento Community Magento Community
Magento Community
Magento Community
 
theconsul
Jr. Member
 
Total Posts:  5
Joined:  2008-10-28
 

hi

same problem for me too

shared hosting and host will not change he settings

my php info: http://www.trendygeschenken.be/info.php

trying to install the latest version of magento and getting also

PHP Extension "pdo_mysql" must be loaded

for all i have seen it seems that there is no standard way to fix this?

any suggestions welcome too

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@ theconsul: From what I see the server you are hosted on does not have pdo_mysql loaded. As such, I suggest you to contact your hosting provider on whether they are able to load that for you. Otherwise your only way is to switch host.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 5