Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error: Class ‘Mage_Catalog_Model_Entity_Setup’ not found in /home…
 
foodstor
Jr. Member
 
Total Posts:  20
Joined:  2007-11-06
 

Fatal error: Class ‘Mage_Catalog_Model_Entity_Setup’ not found in /home/mysite/public_html/magento/app/code/core/Mage/CatalogRule/Model/Entity/Setup.p

This occurred after restoring my crsahed server.  It appears that I have all required extensions installed, and nothing else has changed.  Any ideas ?

Warning: include(Mage/Catalog/Model/Entity/Setup.php[function.include]failed to open streamNo such file or directory in /home/mysite/public_html/magento/app/code/core/Mage/Core/functions.php on line 41
[0] in __autoload
() in /home/mysite/public_html/magento/app/code/core/Mage/Core/functions.php on line 41
[1] in __autoload
("Mage_Catalog_Model_Entity_Setup"in /home/mysite/public_html/magento/app/code/core/Mage/CatalogRule/Model/Entity/Setup.php on line 22
[2] in 
include("/home/mysite/public_html/magento/app/code/core/Mage/CatalogRule/Model/Entity/Setup.php"in /home/mysite/public_html/magento/app/code/core/Mage/Core/functions.php on line 41
[3] in __autoload
("Mage_CatalogRule_Model_Entity_Setup"in /home/mysite/public_html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php on line 81
[4] in Mage_Core_Model_Resource_Setup
::applyAllUpdates() in /home/mysite/public_html/magento/app/code/core/Mage/Core/Model/Config.php on line 135
[5] in Mage_Core_Model_Config
->init(NULLin /home/mysite/public_html/magento/app/code/core/Mage/Core/Model/App.php on line 126
[6] in Mage_Core_Model_App
->init("base"NULLin /home/mysite/public_html/magento/app/Mage.php on line 358
[7] in Mage
::app("base"NULLin /home/mysite/public_html/magento/app/Mage.php on line 378
[8] in Mage
::run("base"in /home/mysite/public_html/magento/index.php on line 28

Warning
: include() [function.include]Failed opening 'Mage/Catalog/Model/Entity/Setup.php' for inclusion (include_path='.:/usr/local/lib/php:/home/mysite/public_html/magento/lib:/home/mysite/public_html/magento/app/code/core:/home/mysite/public_html/magento/app/code/local:/home/mysite/public_html/magento/app/code/community'in /home/mysite/public_html/magento/app/code/core/Mage/Core/functions.php on line 41
[0] in __autoload
() in /home/mysite/public_html/magento/app/code/core/Mage/Core/functions.php on line 41
[1] in __autoload
("Mage_Catalog_Model_Entity_Setup"in /home/mysite/public_html/magento/app/code/core/Mage/CatalogRule/Model/Entity/Setup.php on line 22
[2] in 
include("/home/mysite/public_html/magento/app/code/core/Mage/CatalogRule/Model/Entity/Setup.php"in /home/mysite/public_html/magento/app/code/core/Mage/Core/functions.php on line 41
[3] in __autoload
("Mage_CatalogRule_Model_Entity_Setup"in /home/mysite/public_html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php on line 81
[4] in Mage_Core_Model_Resource_Setup
::applyAllUpdates() in /home/mysite/public_html/magento/app/code/core/Mage/Core/Model/Config.php on line 135
[5] in Mage_Core_Model_Config
->init(NULLin /home/mysite/public_html/magento/app/code/core/Mage/Core/Model/App.php on line 126
[6] in Mage_Core_Model_App
->init("base"NULLin /home/mysite/public_html/magento/app/Mage.php on line 358
[7] in Mage
::app("base"NULLin /home/mysite/public_html/magento/app/Mage.php on line 378
[8] in Mage
::run("base"in /home/mysite/public_html/magento/index.php on line 28


Fatal error
: Class 'Mage_Catalog_Model_Entity_Setup' not found in /home/mysite/public_html/magento/app/code/core/Mage/CatalogRule/Model/Entity/Setup.php on line 22
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi cache,

It looks like not all of the Magento files were restored. Could you make a fresh install ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top