Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP5 auf PHP4 Server CGI-bin
 
fguenzel
Jr. Member
 
Total Posts:  3
Joined:  2008-02-02
 

Hallo,

ich weiß ihr könnt es vielleicht nicht mehr lesen, aber Magento geht bei mir noch immer nicht wegen php5 auf php4 server.

Ich habe jeden Post gelesen im englischen Forum wie auch im deutschen, aber es funtzt einfach nicht!

Meine Ordnerstruktur auf FTP sieht wie folgt aus

html/cgi-bin/
html/magento/

die .htaccess sieht so aus:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

Action php5-cgi /../cgi-bin/php5-cgi
AddHandler /../php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

# Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

# Order allow,deny
# Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

wenn ich so probiere die index.php zu starten kommt der legendäre 500 Internal Server Error.

wenn ich aber in der .htaccess das cgi-bin wie folgt auskommentiere:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /../cgi-bin/php5-cgi
# AddHandler /../php5-cgi .php

kommt der Fehler

Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.

Die .htaccess Einstellungen unter http://www.magentocommerce.com/knowledge-base/entry/installing-magento-on-a-php4-server
haben gar nichts gebracht.

Könnt ihr mir bitte weiter helfen!!!

Danke im Voraus,
Frank

 
Magento Community Magento Community
Magento Community
Magento Community
 
kulimuli
Sr. Member
 
Total Posts:  151
Joined:  2008-03-31
Linz, Oberösterreich
 

Hi,

hast Du Zugriff auf die Apache Logs, wenn ja wird ein Fehler gelogt?

Die Zeichen
<code>
/../
</code>

in den Zeilen

<code>
Action php5-cgi /../cgi-bin/php5-cgi
AddHandler /../php5-cgi .php
</code>
iritieren mich etwas…

 
Magento Community Magento Community
Magento Community
Magento Community
 
fguenzel
Jr. Member
 
Total Posts:  3
Joined:  2008-02-02
 
kulimuli - 28 August 2008 12:13 PM

Hi,

hast Du Zugriff auf die Apache Logs, wenn ja wird ein Fehler gelogt?

Die Zeichen
<code>
/../
</code>

in den Zeilen

<code>
Action php5-cgi /../cgi-bin/php5-cgi
AddHandler /../php5-cgi .php
</code>
iritieren mich etwas…

Hi, ich habe leider keinen Zugriff auf die Apache logs.

das /../ habe ich eingefügt, da mein Ordner mit der cgi-php5
1Ordner über dem Magento ordner liegt...so hab ich das eigentlich auch verstanden nach
Knowledge Base?!
Aber wenn ich in der htaccess den normalen code angebe mit
Action php5-cgi cgi-bin/php5-cgi
AddHandler php5-cgi .php
bedeutet das doch, dass der cgi-bin ordner mit im Magento ordner liegt, oder nicht?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kulimuli
Sr. Member
 
Total Posts:  151
Joined:  2008-03-31
Linz, Oberösterreich
 

Hi, da ist keine Pfadangabe zu machen dies ist der String welcher in der apache.conf für php5 Code hinterlegt ist…

Action application/x-httpd-php5 “/cgi-php/php-cgi”

Wenn z.B. dies in der httpd.conf bzw. apache.conf steht muss “AddType application/x-httpd-php5 .php” in die .htaccess eingetragen werden.

Im Zweifel den Provider fragen…

LG
kulimuli

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top