Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Is anyone successfully using Payflow Pro? Exception thrown Zend::Http::Client request() method. 
 
jbova
Member
 
Avatar
Total Posts:  42
Joined:  2008-07-17
New Ringgold, PA, USA
 

Hello all!

I have been trying to use Payflow Pro with Magento. I have exceptions turned on, and I get a backtrace stopping at the request() function call in Zend_Http_Client package. I will paste that below. I saw another user had the same problem, but his questions were unanswered. I hope to provide additional information.

My Magento version is 1.1.3. I do not have any extensions installed.

I am able to make a test PHP script and use the Zend_Http_Client to create a simple GET request and then print the decoded response body. Therefore, I believe that package is working.

I am having a great deal of trouble trying to raise any errors to the top, or have them added to the exception.log. Can anyone point me in the right direction there? The site reads, “There was an error processing your order. Please contact us or try again later.” in a javascript alert. This is useless to me. How can I get more debugging information on the web page or in the log? Any die statements or exceptions I throw from the lib/Zend/Http/Client.php or lib/Varien/Http/Client.php file are discarded. The result is a javascript alert that reads “Undefined” and no additional information in the exception.log.

Even if no one has the solution to my Payflow problem, possibly someone with experience can help me with proper debugging procedures in Magento?

( Backtrace below )

Thanks,
Jim

2008-08-27T20:15:53+00:00 ERR (3):
#0 /var/www/vhost/yipeeee/docroot/htdocs/lib/Varien/Http/Client.php(50): Zend_Http_Client->request(NULL)
#1 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Paygate/Model/Payflow/Pro.php(336): Varien_Http_Client->request()
#2 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Paygate/Model/Payflow/Pro.php(87): Mage_Paygate_Model_Payflow_Pro->_postRequest(Object(Mage_Paygate_Model_Payflow_Pro_Request))
#3 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Sales/Model/Order/Payment.php(118): Mage_Paygate_Model_Payflow_Pro->authorize(Object(Mage_Sales_Model_Order_Payment), 25)
#4 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Sales/Model/Order.php(337): Mage_Sales_Model_Order_Payment->place()
#5 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Sales/Model/Order.php(472): Mage_Sales_Model_Order->_placePayment()
#6 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Checkout/Model/Type/Onepage.php(437): Mage_Sales_Model_Order->place()
#7 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Checkout/controllers/OnepageController.php(359): Mage_Checkout_Model_Type_Onepage->saveOrder()
#8 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(343): Mage_Checkout_OnepageController->saveOrderAction()
#9 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(144): Mage_Core_Controller_Varien_Action->dispatch('saveOrder')
#10 /var/www/vhost/yipeeee/docroot/htdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(168): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#11 /var/www/vhost/yipeeee/docroot/htdocs/app/Mage.php(420): Mage_Core_Controller_Varien_Front->dispatch()
#12 /var/www/vhost/yipeeee/docroot/htdocs/index.php(46): Mage::run()
#13 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
zindrew
Jr. Member
 
Total Posts:  30
Joined:  2009-03-28
 

I am getting the same error with PayFlow Pro “There was an error processing your order. Please contact us or try again later.”, Where you or anyone else able to find a solution to this??

 
Magento Community Magento Community
Magento Community
Magento Community
 
doughold
Jr. Member
 
Total Posts:  12
Joined:  2009-04-03
 

I am having the same issue, my cart was working fine one day and then wasn’t the next, no updates were even installed...if anyone can figure this out let me know. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top