Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Products not showing up in categories…
 
keadie
Jr. Member
 
Total Posts:  7
Joined:  2008-08-14
 

Greetings all and thank you for reading.  I installed Magento 1.1.3 a couple of days ago and have been playing with it.

Yesterday I removed everything and started from scratch and imported my data for our live OSCommerce site.  Everything was working fine than and I made a backup.

Today I started fiddling with the settings again and now I cannot browse for products.  I can search for them, but nothing show up when I click on a category.

I emptied the magento table and restored from backup to no avail. 

The last configuration I played with was the system->configuration->catalog->catalog, but it could be any of them above that.

Anybody have any idea what happened?

Thanks!

- Kyle

 
Magento Community Magento Community
Magento Community
Magento Community
 
mvf1981
Jr. Member
 
Total Posts:  4
Joined:  2008-09-06
 

Hi,

I have a similar problem .
Last thing I did was trying to add a featured category - which did not work. Now I have lost all my products under the category view.
If I search for them I can still see them.

Did you ever find a solution to this problem?

Mark.

 
Magento Community Magento Community
Magento Community
Magento Community
 
keadie
Jr. Member
 
Total Posts:  7
Joined:  2008-08-14
 

Sorry mvf1981, I started from scratch.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mvf1981
Jr. Member
 
Total Posts:  4
Joined:  2008-09-06
 

Thanks for the update,

I too have had to reinstall!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Parsoya
Jr. Member
 
Total Posts:  6
Joined:  2008-09-17
Ahmedabad Gujarat India
 

I am also facing the same problem. I think there are some technical problem in magento which made it lost during the surfing of the products through the path of categories . It might be some session or any other problem. Similarly when I search the products I am able to search all the products but when I go through the path of category and subcategory it lost it path someway and again get resumed after period of some click of various categories. Can anyone help me to sort out this problem ?? Solution provider will be appreciated heartily. Thanks a lot in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackied
Member
 
Total Posts:  31
Joined:  2008-07-02
 

I’m having the same problem with products not showing up in the categories, only in the search.

Any help would be awesome! Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackied
Member
 
Total Posts:  31
Joined:  2008-07-02
 

I figured out the solution to my issue..... I was putting the products in the wrong categories. The categories must be sub categories of the Default Category.

 
Magento Community Magento Community
Magento Community
Magento Community
 
amontobin
Jr. Member
 
Total Posts:  7
Joined:  2008-10-02
 
Parsoya - 25 September 2008 09:09 PM

I am also facing the same problem. I think there are some technical problem in magento which made it lost during the surfing of the products through the path of categories . It might be some session or any other problem. Similarly when I search the products I am able to search all the products but when I go through the path of category and subcategory it lost it path someway and again get resumed after period of some click of various categories. Can anyone help me to sort out this problem ?? Solution provider will be appreciated heartily. Thanks a lot in advance.

I’ve got a similar problem.  While inputting the catalog (which was working fine) everything in the category view suddenly disappeared.

I can still find products using search, and the breadcrumb trail still works.  However, navigating to the parent category from the breadcrumb trail goes to an empty category.

 
Magento Community Magento Community
Magento Community
Magento Community
 
amontobin
Jr. Member
 
Total Posts:  7
Joined:  2008-10-02
 

I’ve got a similar problem.  While inputting the catalog (which was working fine) everything in the category view suddenly disappeared.

I can still find products using search, and the breadcrumb trail still works.  However, navigating to the parent category from the breadcrumb trail goes to an empty category.

Nevermind, this was me being stupid.
Trying to change the “Continue Shopping” destination ala http://www.magentocommerce.com/boards/viewthread/10066/

 
Magento Community Magento Community
Magento Community
Magento Community
 
lizlux
Member
 
Avatar
Total Posts:  40
Joined:  2009-08-03
 

Has anyone gotten any help on this?  I too was trying to do the add a featured category option, and it didn’t work for me either.  Now my category pages are not turning up with products. 
Has anyone from Magento looked at this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lizlux
Member
 
Avatar
Total Posts:  40
Joined:  2009-08-03
 
lizlux - 06 August 2009 02:28 PM

Has anyone gotten any help on this?  I too was trying to do the add a featured category option, and it didn’t work for me either.  Now my category pages are not turning up with products. 
Has anyone from Magento looked at this?

I ended up re-installing my app folder and it’s working now.  Good thing this is still a new project or that could have been a bummer!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mikeray
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-07-23
 

This same exact problem occurred. I installed a featured product Module and now the products have disappeared. Not cool as this was the very last thing I had to do before the project was completed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vikas_rao
Member
 
Total Posts:  57
Joined:  2013-10-02
 

Products are not displaying under categories section. Please check the link http://joinery.newtrendzonline.com/

We uploaded about 2000 products. Before all Products were displaying. now no products are displaying if we click on categories section.

But products are dislaying in home page, search box, using url, but not displaying under categories.

I am struggling for this.

Can anyone give me the solution.

Thanks in Advance..

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top