Magento Forum

   
Can’t save product under IE 7
 
gp01fb
Member
 
Total Posts:  34
Joined:  2008-07-09
 

Hi,

I encounter an error when I try to save the product. Below is the error message:

Recoverable Error: Argument 1 passed to Varien_Object::addData() must be an array, null given, called in /home/ehobacom/public_html/shop/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 338 and defined in /home/ehobacom/public_html/shop/lib/Varien/Object.php on line 172

I can save the same product with the same information without error under Firefox. But when I use IE 7, the above message pops up. This product was imported via the import profile. I also tried to add a new product via admin panel using IE 7, but the same error message pops up. Does anyone know what’s the problem?

I’ve searched the forum about this and no replies were available to previous posts regarding this issue. Just wonder if anyone has experienced this error before and was able to fix it.

Thank you very much.

Horace

 
Magento Community Magento Community
Magento Community
Magento Community
 
thinkflair
Jr. Member
 
Total Posts:  1
Joined:  2008-09-08
 

I’m also getting this error, also only in IE and not in firefox:

Recoverable Error: Argument 1 passed to Varien_Object::addData() must be an array, null given, called in /home/../public_html/store/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 241 and defined in /home/../public_html/store/lib/Varien/Object.php on line 170

Help would be greatly appreciated as there are situations where only IE is available.

 
Magento Community Magento Community
Magento Community
Magento Community
 
augirl
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2008-07-21
 

Hi

Not sure if you’ve solved your problem yet, however, I had a similar issue and it was due to my adding one of the wysiwyg text editors.  One of them has some javascript that IE7 didn’t like.  It either needs to be removed or tidied up.

HTH

 
Magento Community Magento Community
Magento Community
Magento Community
 
gp01fb
Member
 
Total Posts:  34
Joined:  2008-07-09
 

The problem still haven’t solved yet. What is the wysiwyg test editors are you referring to? I did not see any editor on the product edit page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
augirl
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2008-07-21
 

Hi

I had installed the tinymce wysiwig editors and it had left some redundant javascript code in the page and as IE7 is’ very picky’ about incorrect or redundant javascript it resulted in the problem you are having.  If you haven’t installed a wysiwig, have you installed any other extensions or addons?  Check out the code or try removing it and seeing if you still have the problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cole Geissinger
Sr. Member
 
Avatar
Total Posts:  174
Joined:  2008-12-23
Northern California
 

Hi,
I too get this error, but I am receiving it in FireFox 3.0.10. Any solutions? I can by pass this by hitting the save button again but I would like to see what is going on here.
I am using Mage 1.0.3. Any hints would be helpful.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top