Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Navigation (menu bar) disappeared when categories deleted
 
websitebob
Member
 
Total Posts:  33
Joined:  2008-04-16
 

Greetings

I’ve worked with several open source shopping carts. This is my first cart on Magento. It has a lot of potential.

Here’s the puzzle I’m working on today:
I created a category. Anchored it and filled it with products. Enabled it. The corresponding link appeared on the navigation menu across the header on the front end. (Woo hoo....success!)

I changed my mind. Deleted the category. Wiped it out clean. Then, created a new category, anchored it, enabled it, filled it with products etc. etc. ...but the nav bar did not reappear.  (Dooh!...now why did I do that?) Tried recreating categories several times, searched the control panel for navigation access, searched Google...okay, I give. Now, I’m searching you.

Does anyone have an idea of what happened, or more importantly, how I can recover the nav bar?

Thanks in advance
websitebob

 
Magento Community Magento Community
Magento Community
Magento Community
 
misterMan
Member
 
Total Posts:  57
Joined:  2008-07-15
 

You simply need to make sure you have it under the root category in the tree. The Root category is invisible, but all your other categories have to show up under it in the Catalog>Manage Categories tab in the Admin. That’s how they appear in the frontend.

I did the same thing. Not sure why but that’s how it works.

If you’ve deleted the Root category you can recreate it I believe.

Good Luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
websitebob
Member
 
Total Posts:  33
Joined:  2008-04-16
 

@misterMan

Thanks for the reply.

Actually, I did save it under the Root. Still nada, nyet, not a thing.

Hmmmmm.....back to the chalkboard...surely something simple.

websitebob

 
Magento Community Magento Community
Magento Community
Magento Community
 
websitebob
Member
 
Total Posts:  33
Joined:  2008-04-16
 

Solved

You have to reset the categories under System > Manage Stores > Select the Store Name > select the new category to activate.

Related post: http://www.magentocommerce.com/boards/viewthread/4250/

This will come up again and again. I would never have guessed the default/root category setting is located here.

Good luck
websitebob

 
Magento Community Magento Community
Magento Community
Magento Community
 
aeolous
Jr. Member
 
Total Posts:  4
Joined:  2008-10-03
 

wow!!! me either… thanks websitebob… same problem here

 
Magento Community Magento Community
Magento Community
Magento Community
 
Letsnurture
Jr. Member
 
Total Posts:  4
Joined:  2008-12-24
 

Hi folk,

I’m a new to Magento and this theread helped me a lot to build top bar navigation in Magento.

Well, one only need to add the new category under “default category”. Doing so Magento will display that new category in top navigation bar.

The reason why does it not appear in the navigation bar is we directly add new category at same level of “default category”. Here one first needs to click on “Default category” and then “Add subcategory”. And it works!!!!

As far as I know, this top bar navigation is built for category only. Is it possible to list CMS page along with top navigation bar which is in header section of the website.

Is there any good developer’s manual/guide to learn,ride and play with magento?

Thanks again for sharing great knowledge

--
Web-Farmer @
http://www.letsnurture.com

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top