Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

{solved} Installation tries to access “"/index.php/install/” and fails with a 404. 
 
romanceculture
Jr. Member
 
Total Posts:  5
Joined:  2008-07-30
 

I’ve downloaded the magento downloader and copied it to our website http://magento.romanceculture.com/
The download process went fine, the installation however fails The Installer tries to access “/index.php/install/”, which cannot be found.

If I manually go to http://magento.romanceculture.com/installation/ I can see the first page of Magento Installation Wizzard.
When however clicking “continue”, I again end up in a non-existing file.

The apache log file says:

155.69.221.193 - - [20/Aug/2008:13:02:48 +0000] “POST /index.php/install/wizard/beginPost/ HTTP/1.1” 302 195 “http://magento.romanceculture.com/install/” “Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1”

Here’s my phpinfo: https://www.romanceculture.com/info.php if that should matter. I haven’t modified anything from the .htaccess which came with the installation.

Is there something wrong with the redirections or rewrites? I’ve tried to install magento for over 12hours now and am getting a bit frustrated. Hope someone has a hint.

 
Magento Community Magento Community
Magento Community
Magento Community
 
OSSAnalyst
Jr. Member
 
Total Posts:  5
Joined:  2008-07-30
Manchester, UK
 

It does sound like your redirects are not being picked up and there are two things that you should check.

Firstly, I assume from your post that you are unpacking all the magento files into the root directory for your site instead of a magento directory. If you unpack all the files into a /magento directory in the root of your site, for example, then you need to set the RewriteBase option in the .htaccess file to match. So if you have a /magento directory, the RewriteBase option should also be /magento/

If that is fine, then perhaps your configuration does not allow the .htaccess file to override the system configuration to turn on the Rewrite Engine. The easiest solution to this, is to add the AllowOverride All to the directory where your site is served from. For example, with your files in /users/home/romanceculture/web/public you should add something like this to the configuration of your apache host:

<Directory /users/home/romanceculture/web/public>
AllowOverride All
</Directory>

You may already have options for this directory so just add the AllowOverride directive to them. Often the system default is AllowOverride None.

 
Magento Community Magento Community
Magento Community
Magento Community
 
romanceculture
Jr. Member
 
Total Posts:  5
Joined:  2008-07-30
 

I found the problem to be something related to the URL mapping. On Joyent shared accelerators, if you have a folder under ~/web/public/, it is automatically mapped to a subdomain. So ~/web/public/www/ would be accessible via http://www.yourdomain.com. I had a subfolder ~/web/public/magento, so I assumed it was accessible via magento.domain.com (which was kind of the case). For still unknown reason, I had problems with the magento installation when going through http://magento.domain.com (though the installation page seemed to load fine). After switching to the URL http://domain.com/magento (which is supposed to map to the same location as http://magento.domain.com), the installation went fine.

This is voodo.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top