Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How can I link Product-Pictures (Thumbs) to a CMS Single-Page? 
 
basty
Jr. Member
 
Total Posts:  16
Joined:  2008-08-10
North-Germany
 

In an earlier version of Magento (1.0.x I think), you simple add something like this in your CMS Page (the “Home"-Page for example) to include a product-image in your page:

<p><a href="{{store url=""}}name-of-my-super-special-product-item">
<
img class="product-img" src="{{skin url='images/media/best_selling_product_item_01.jpg'}}" alt="" width="95" /></a></p>

Now, i have the version 1.1.2/1.1.3 and all images are cached! So if i browse to the catalog to find my product whitch i would like to insert on my “Home"-Page, click right on it to view the properties (thumb or realsize image), i see something like this:

- http://www.mydomain.com/media/catalog/product/cache/1/small_image/135x135/5e06319eda06f020e43594a9c230972d/h/a/test_product_01.gif
- http://www.mydomain.com/media/catalog/product/cache/1/image/5e06319eda06f020e43594a9c230972d/h/a/test_product_01.gif

OK, i can link to this,…
BUT: The directory-name “5e06319eda06f020e43594a9c230972d” looks like a (random) hash-value, so i think it will be changed always the cache is rebuild (after clearing). So the link from the static CMS page will be wrong when the cache is rebuilded. Is it right?

How can I insert image-links where i can be sure, that they will always work?

Thanks for answers! smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
ryanb
Sr. Member
 
Total Posts:  91
Joined:  2008-02-15
 

I would like to know this too—all of our datafeeds are not working with new products after the 1.1.3 upgrade. This is because the image URLs indicate on the export do not work—there are only the crazy cache URLs.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top