Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SQLSTATE[42S01]: Base table or view already exists
 
hobby
Jr. Member
 
Total Posts:  2
Joined:  2008-08-16
 

I am getting this error on my initial installation.

To get to this point I have downloaded the full version 1.1.3.  I have unzipped the package and uploaded via ftp.  I have set the permissions as instructed on the app/etc, media, var folders as instructed.  When I navigate to the magento install wizard, everything loads up fine.  I get through the local settings fine.  When I finish imputting the configuration data I get the following error when I continue with the installation.

Error in file: “/home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Sales/sql/sales_setup/mysql4-install-0.9.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘sales_flat_quote’ already exists
Trace:
#0 /home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(280): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(160): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘0.9.14’)
#2 /home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(148): Mage_Core_Model_Resource_Setup->_installResourceDb(’0.9.14’)
#3 /home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(114): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Core/Model/Config.php(209): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/users/h/hobbytohobby/public_html/magento/app/code/core/Mage/Core/Model/App.php(230): Mage_Core_Model_Config->init(Array)
#6 /home/users/h/hobbytohobby/public_html/magento/app/Mage.php(397): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /home/users/h/hobbytohobby/public_html/magento/app/Mage.php(416): Mage::app(’’, ‘store’, Array)
#8 /home/users/h/hobbytohobby/public_html/magento/index.php(46): Mage::run()

I have read through a lot of help articles and similar questions posted by other members but they all seem to deal with the upgrade of the software and not the initial installation.  I am fairly new to website software installation so if anyone can help me with this problem in lay man’s terms as much as possible, that would be much appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hobby
Jr. Member
 
Total Posts:  2
Joined:  2008-08-16
 

I was able to get this to work finally but I had to remove all magento files from my web hosting, reset my permissions with my server, and load magento again using the installer package.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ANDI222
Member
 
Avatar
Total Posts:  41
Joined:  2008-02-26
 

Can you please explain how did you recover you database?

I have the same error on http://www.cameredesupraveghere.eu !

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ccoder
Jr. Member
 
Total Posts:  4
Joined:  2008-07-24
 

BUMP any help please?!?!

side note: I’m trying to install on godaddy, i have used the downloader and it consistently freezes while loading the varien-lib1.2.1 or whatever back to trying no downloader now and still getting same error

SQLSTATE[42S01]: Base table or view already exists: 1050

 
Magento Community Magento Community
Magento Community
Magento Community
 
nrolando
Jr. Member
 
Total Posts:  6
Joined:  2012-09-17
 

Seems like magento is trying to rebuild your database. So one way to fix this error is the start with an empty database and configure it in /app/etc/local.xml, then set PHP’s max_execution_time to like 300 seconds and run the home page. It will rebuild the DB. Though I’m still trying to figure how to log into admin now lol smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top