Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Internal Server Error Message - Thoughts Appreciated! 
 
craigsmith33
Jr. Member
 
Total Posts:  7
Joined:  2007-09-02
 

Getting this error on install and it seems Im not alone.
--------------------------------------------------------------
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
--------------------------------------------------------

I am newbie who tries to troubleshoot my way through these type of installs.  Any help would REALLY be appreciated since their is not much documentation obviously.

Is this an .htaccess problem?  It didnt match the earlier description and also I host with GoDaddy and I think it is on with them (I used it in an OSCommerce build).

Any other ideas?  Thanks and I cant wait to test the product!

 
Magento Community Magento Community
Magento Community
Magento Community
 
bradgman
Jr. Member
 
Total Posts:  13
Joined:  2007-09-01
Chciago IL
 

PHP 5.2?
Try Running a file with <?php phpinfo(); ?> in it and see what version you are running.

Misconfigured Apache?
If the previous mentioned file runs then Apache is at least running.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tobz
Jr. Member
 
Total Posts:  18
Joined:  2007-09-02
 

change .htaccess rewrite rules to:

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

 
Magento Community Magento Community
Magento Community
Magento Community
 
craigsmith33
Jr. Member
 
Total Posts:  7
Joined:  2007-09-02
 

Im actually in PHP 4 but have made the modifciations to run 5 by adding the required cgi-bin file and change the .htaccess to point at it.  Still no luck but going to try Tobz’s suggestion with fingers crossed!

 
Magento Community Magento Community
Magento Community
Magento Community
 
craigsmith33
Jr. Member
 
Total Posts:  7
Joined:  2007-09-02
 

No luck - here is my .htaccess - does it look correct??
-----------------------------------------------------------------
php_flag magic_quotes_gpc off
php_flag short_open_tag on

Action php5-cgi /php5-cgi
AddHandler php5-cgi .php

DirectoryIndex index.php

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tobz
Jr. Member
 
Total Posts:  18
Joined:  2007-09-02
 

remove or comment out:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php

eg:

php_flag magic_quotes_gpc off
php_flag short_open_tag on

Action php5-cgi /php5-cgi
AddHandler php5-cgi .php

DirectoryIndex index.php

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !-l

#RewriteRule .* index.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
ninamelendez
Jr. Member
 
Total Posts:  8
Joined:  2007-09-01
 

Hi,

I’ve read all the documentation. I’ve gone through SSH, updated HTACCESS, and verified that I have PHP 5.2.0 on my server. No matter what, I’m getting the same error as the rest of you.

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JaNCo
Jr. Member
 
Total Posts:  1
Joined:  2007-09-02
 

I have the same problem :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

this is a httpd.conf problem.

try looking into Allowoverride settings.

make sure you set it to all

 
Magento Community Magento Community
Magento Community
Magento Community
 
misterniall
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2007-09-03
Montreal
 

Not Sure if this is the exact problem you are having with your install. However, if for example you are using Site5 hosting then the php_flag options in .htaccess will not work.  instead you will need to create a custom php.ini and set the flags in there or some other appropriate alternative. At the same time you could enable php5 instead of php4 (for Site5).

try commenting out the following

php_flag magic_quotes_gpc off
php_flag short_open_tag on

in .htaccess

Alternatively if you have access to the php error logs look and see what is being thrown.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tweakmag
Guru
 
Avatar
Total Posts:  307
Joined:  2007-08-31
London, UK
 

You could also try enabling mod_rewrite in httpd.conf

 
Magento Community Magento Community
Magento Community
Magento Community
 
craigsmith33
Jr. Member
 
Total Posts:  7
Joined:  2007-09-02
 

When you say it is a httpd.conf problem - can you eleborate a bit more please?  I imagine it is just a change in a file named httppd.conf?  Can you provide insights into the location of this file? 

thanks so much..

 
Magento Community Magento Community
Magento Community
Magento Community
 
misterniall
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2007-09-03
Montreal
 
craigsmith33 - 03 September 2007 09:22 AM

When you say it is a httpd.conf problem - can you eleborate a bit more please?  I imagine it is just a change in a file named httppd.conf?  Can you provide insights into the location of this file? 

thanks so much..

The httpd.conf is the configuration file for Apache server.  More than likely if this is on a hosted machine then you will not have access to it as it will require a restart of the server. 

The best solution would to provide more information. Are you using hosting and if so with whom? what access do you have to make changes?  What logs do you have access to etc.  Sorry but I think with some more information this could be solved much more quickly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
milosradovic
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2007-09-04
St.Gallen, Switzerland
 

I had the same problem. And I solved it pretty fast. I did the following steps:

1. In httpd.conf “AllowOverride” was set to “None"… change this to: “AllowOverride All”

2. replace the standard .htaccess with the following code:

php_flag magic_quotes_gpc off
php_flag short_open_tag on

DirectoryIndex index.php

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !-l

#RewriteRule .* index.php

3. Activate mod_rewrite by removing # from the followoning line in the httpd.conf: #LoadModule rewrite_module modules/mod_rewrite.so

4. Restart your Apache

5. Done!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top