Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Converting Simple products into Virtual products
 
markl
Member
 
Total Posts:  39
Joined:  2008-04-18
 

Hi,

All my products have been entered as simple products, but they are being supplied as a service, so they have no shipping fee. From what I’ve just read in the user guide, I think that they should have been entered as virtual products. Is there a way to convert them fom simple to virtual?

Thanks,

Mark

 
Magento Community Magento Community
Magento Community
Magento Community
 
kramusica
Member
 
Total Posts:  55
Joined:  2008-07-16
 

Magento can’t convert simple products into virtual products. You will have to create your products again as virtual products.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ramedia
Member
 
Total Posts:  70
Joined:  2008-05-17
 

Try editing the database directly.  First, back up your database!  Then change magento_catalog_product_entity > edit a product and change type_id from “simple” to “virtual.” Hopefully that will be all you need to do.  Again, back up your database before altering it, and thoroughly test your changed sample product before committing to the change.

 
Magento Community Magento Community
Magento Community
Magento Community
 
markl
Member
 
Total Posts:  39
Joined:  2008-04-18
 

Thanks guys. I just finished entering the last of the products about 10 minutes ago. It took 3 hours =( Ah well, it was worth it now that my checkout process has dropped from 6 to 4 steps minus the shipping part.

I had thought about modifying the tables directly, but decided that knowing my luck, product types would be stored elsewhere and I’d end up with a corrupt DB. That’s of course before I read your post Ramedia, so I might have got away with it.

Thanks for the advice,

Mark

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top