Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 5
Help! changing admin url broke admin
 
a2b2c2d
Jr. Member
 
Total Posts:  13
Joined:  2008-07-21
 

I used the admin feature to change the admin url however, after I applied the setting it is giving me an internal 500 server error whenever i try and access the admin panel at admin/

My new admin directory that i set simply redirects within magento as if page was not found.  I tried editing admin/url/use_custom in core_config_data database from 1 to 0 hoping to turn it off and fix the issue but no luck. 

Ideas???? This is a site that just went live and I figured that was a simple config change, nothing that could cause something this catastrophic.  Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
a2b2c2d
Jr. Member
 
Total Posts:  13
Joined:  2008-07-21
 

It would appear every time I try to load the default admin url, it is generating a core dump file in the store directory.  What do I do?

 
Magento Community Magento Community
Magento Community
Magento Community
 
a2b2c2d
Jr. Member
 
Total Posts:  13
Joined:  2008-07-21
 

This is what I could get from the core dump:

Program terminated with signal 11, Segmentation fault.
#0 0x00000000006ae66d in execute (op_array=0x2a96cc1ff8) at /home/cpeasyapache/src/php-5.2.6/Zend/zend_vm_execute.h:70
70 EG(This)->refcount--;

 
Magento Community Magento Community
Magento Community
Magento Community
 
a2b2c2d
Jr. Member
 
Total Posts:  13
Joined:  2008-07-21
 

Clearing magento’s cache store/var/cache has seemed to stop the 500 internal server error

 
Magento Community Magento Community
Magento Community
Magento Community
 
mlusher
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2008-06-23
Longmont , CO
 

I have similar issue. I thought I was tightening up security but now I get this weird blank page with most of the navigation links of the admin but everything I click results in a 404.  I can’t even see the Admin link where I changed the setting in the first place.  Any ideas on how to fix it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mlusher
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2008-06-23
Longmont , CO
 

Clearing the cache didn’t help me.  Any other ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Incognito
Guru
 
Total Posts:  322
Joined:  2008-08-07
Michigan
 

I had the same problem. It was fixed it by going into the core_config_data table and deleting the last records.  The records should have the words, in the value feild, you tried to change the url to.  Then you have to clear you cache by deleting all the mage--* directories.  I also restarted my apache, but i don’t know if that was necessary.  I am still unable to change the admin url without a problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jbragg
Jr. Member
 
Total Posts:  5
Joined:  2008-09-04
 

“I have similar issue. I thought I was tightening up security but now I get this weird blank page with most of the navigation links of the admin but everything I click results in a 404.  I can’t even see the Admin link where I changed the setting in the first place.  Any ideas on how to fix it?”

Same issue. I did everything above and now only see a text page for the admin page with links and anytime i select a page i get a 404 at the bottom.

Update---Problem fixed--

ok this is how i fixed it.

When into phpmyadmin into core_config_data on the last page i deleted the entire fields not just the data in them

Edit Delete 96 default 0 admin/url/use_custom
Edit Delete 97 default 0 admin/url/custom
Edit Delete 98 stores 0 web/secure/base_url
Edit Delete 99 stores 0 web/unsecure/base_url

this fixed everything. Admin is back 100% with all features working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MarcP21
Jr. Member
 
Total Posts:  7
Joined:  2008-09-17
 

try this www.yourdomain.com/magento/index.php/admin

 
Magento Community Magento Community
Magento Community
Magento Community
 
RackOutfitters.com
Jr. Member
 
Total Posts:  2
Joined:  2008-09-25
 

Wonder how many will get snared in this trap before Magento adds some type of warning or fix.  I too wanted to make my admin access a little less obvious than “www.site.com/admin”, and changed it to admin/password/ that’s when it all went wrong as described in the previous posts.  Glad the posts were available, unfortunately, after deleting the phpadmin files as outlined it’s still not fixed for me.  Still plain HTML and 404 errors.  Could be that I don’t know how to delete the cache properly.  I deleted the browser cache but I doubt that this is the cache that’s being discussed.  Any additional help on this is appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
RackOutfitters.com
Jr. Member
 
Total Posts:  2
Joined:  2008-09-25
 

Okay, I fixed it by piecing together information from multiple posts.  Here’s the fix in one post:

============Step 1=======================
In phpmyadmin find core_config_data and on its last page deleted the entire fields not just the data in them:
admin/url/use_custom
admin/url/custom
web/secure/base_url
web/unsecure/base_url

==========Step 2=========================
In /public_html/var/cache/ delete all the files:
mage--1 through mage--f

This fixed everything. Admin is back 100% with all features working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tonyrelph
Jr. Member
 
Total Posts:  23
Joined:  2008-10-16
 

Worked like a treat!

Thanks,

Tony.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vicky
Member
 
Avatar
Total Posts:  50
Joined:  2008-09-28
 

Worked perfectly.  Thanks for the effort in keeping us informed.

One note, the cache files are folders and not files.  smile

Vicky

 
Magento Community Magento Community
Magento Community
Magento Community
 
chrissmiss
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-08-13
Münster/Germany
 

Fantastic Job

It worked perfectly

1000 Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
dkoo761
Jr. Member
 
Total Posts:  8
Joined:  2008-10-10
 

Brilliant, thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jon Edwards
Jr. Member
 
Total Posts:  29
Joined:  2008-10-10
 

It seems that my admin URL is broken too… For some reason I can’t access my admin area through the default path of http://mysite.com/index.php/admin/ I get a 404

But when I use a URL for a page within the admin, I get the admin login (because I’m not logged in yet and need to be in order to view that page) For example, if I use http://mysite.com/index.php/admin/dashboard/ I get the login screen.

This approach allows me to get in, but it’s not ideal. Furthermore, when I click the “logout” button, I get a 404 because this directs me to http://mysite.com/index.php/admin/ (which is broken) after logout.

Can someone help me fix this annoyance? I’ve deleted /var/cache.  And under System->Configuration->Admin->Admin Base URL I have Use custom admin URL set to “No”.

Thanks!

Jon

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 5