Magento Forum

Internal Server Error
 
Romana
Member
 
Total Posts:  39
Joined:  2007-09-23
 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache Server at ehand.de Port 80

Die Installation will nicht klappen.

Nach einem Serverwechsel auf einen V-Server sollte es klappen. Der Support meinte, er habe eine zweite .htaccess-Datei eingebunden und es habe funktioniert. Nun habe ich es probiert, habe auch so gut wie keine Ahnung, und nix ging. Ein Bekannter, seines Zeichens Programmierer, hat sich nun damit beschäftigt und kommt mit der Beschreibung des Supports bzw. den vorgeschlagenen Änderungen auch nicht weiter. Auf die .htaccess-Datei ganz zu verichten, hätte zur Folge dass die Webseite und deren Unterseiten gar nicht mehr zu finden wären. Außerdem möchte ich auch nicht auf diese Datei verzichten. grin Nun meinte er, dass möglicherweise die Grundeinstellungen falsch oder nicht mehr vorhanden sein könnten. Welche Grundeinstellungen sind denn hier nötig?

Schon etwas verzeifelt bin.

Ciao,
Romana

Httpd Optionen

PHP safe_mode Ja Nein
PHP register_globals Ja Nein
PHP open_basedir Ja Nein
WebServer mod_rewrite Ja Nein
WebServer error log Ja Nein
WebServer mod_rewrite debug Ja Nein
PHP memory limit Ja Nein
PHP upload file size Ja Nein
PHP debug Ja Nein

 
Magento Community Magento Community
Magento Community
Magento Community
 
chrissmiss
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-08-13
Münster/Germany
 

Hi, die Fehlermeldung kann ich auch reproduzieren.
Habe in der .htaccess die Zeile:

# Options +FollowSymLinks

auskommentiert, dann läuft es. Vielleicht hilft dir das!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Radi
Member
 
Total Posts:  38
Joined:  2008-07-24
 

Hallo Romana,

hatte auch ein Mal den Server Error es lag daran, dass Magento beim Update die Schreibrechte verändert hat. Habe alles wieder richtig gesetzt und alles war gut.

Ich hoffe Dir hilft das weiter.

Radi

 
Magento Community Magento Community
Magento Community
Magento Community
 
Romana
Member
 
Total Posts:  39
Joined:  2007-09-23
 

Hi,

kann mir wer freundlicherweise bitte sagen was es hier genau zu ändern gäbe um diese Fehlermeldung loszuwerden. An den Schreibrechten liegt es nicht. Ich habe davon keine Ahnung, was ich kann, habe ich mir mal zeigen lassen, doch von diesen Script weiß ich noch nichts. Und der Programmierer meinte, er habe aufgegeben.

Wäre sehr freundlich.

Ciao,
Romana

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
 
chrissmiss
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2008-08-13
Münster/Germany
 

Hi, ich weiss ja nicht ob Du meinen Tip schon versucht hast, deshalb hier noch einmal etwas genauer!

Ändere mal

## enable rewrites
Options +FollowSymLinks
RewriteEngine on

auf

## enable rewrites
# Options +FollowSymLinks
RewriteEngine on

Speichern und ausprobieren.

Geht es noch nicht, dann ergänze zusätzlich

## By default allow all access
Order allow,deny
Allow from all

auf

## By default allow all access
# Order allow,deny
# Allow from all

Speichern und ausprobieren.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Versuchen Sie, Ihre Dateien und Verzeichnisse Berechtigungen.
Wenn Ihr Server läuft suPHP, ändern Sie alle Dateien auf 644 und alle Verzeichnisse auf 755.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Romana
Member
 
Total Posts:  39
Joined:  2007-09-23
 

Hi,

danke Euch erstmal. Hoffe ich muss nicht nochmal nachfragen.

Ciao,
Romana

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Kein Problem. wink
Achten Sie darauf, Bericht erstatten über das Ergebnis dieser. smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top