Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘core_setup’
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 

Hello,

After upgrading from 1.3.2.4 to 1.4.0.1 there is an error.

app/code/core/Zend/Cache dir deleted
cache not activated before upgrade
cache and session dirs also deleted completely
All extensions have been uninstalled before updating

The message is:

a:5:{i:0;s:85:"SQLSTATE[42S22]: Column not found: 1054 Unknown column 'core_setup' in 'where clause'";i:1;s:1761:"#0 /chroot/home/xxxxx/html/staging/lib/Zend/Db/Statement.php(283): Zend_Db_Statement_Pdo->_execute(Array)
#1 /chroot/home/xxxxx/html/staging/lib/Zend/Db/Adapter/Abstract.php(457): Zend_Db_Statement->execute(Array)
#2 /chroot/home/xxxxx/html/staging/lib/Zend/Db/Adapter/Pdo/Abstract.php(230): Zend_Db_Adapter_Abstract->query('UPDATE `mg_core...', Array)
#3 /chroot/home/xxxxx/html/staging/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('UPDATE `mg_core...', Array)
#4 /chroot/home/xxxxx/html/staging/lib/Zend/Db/Adapter/Abstract.php(578): Varien_Db_Adapter_Pdo_Mysql->query('UPDATE `mg_core...', Array)
#5 /chroot/home/xxxxx/html/staging/app/code/core/Mage/Core/Model/Mysql4/Resource.php(131): Zend_Db_Adapter_Abstract->update('mg_core_resourc...', Array, Array)
#6 /chroot/home/xxxxx/html/staging/app/code/core/Mage/Core/Model/Resource/Setup.php(237): Mage_Core_Model_Mysql4_Resource->setDataVersion('core_setup', '0.8.26')
#7 /chroot/home/xxxxx/html/staging/app/code/core/Mage/Core/Model/Resource/Setup.php(198): Mage_Core_Model_Resource_Setup->_installData('0.8.26')
#8 /chroot/home/xxxxx/html/staging/app/code/core/Mage/Core/Model/Resource/Setup.php(178): Mage_Core_Model_Resource_Setup->applyDataUpdates()
#9 /chroot/home/xxxxx/html/staging/app/code/core/Mage/Core/Model/App.php(301): Mage_Core_Model_Resource_Setup::applyAllDataUpdates()
#10 /chroot/home/xxxxx/html/staging/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#11 /chroot/home/xxxxx/html/staging/index.php(78): Mage::run('', 'store')
#12 {main}"
;s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

Has anyody experienced this error before?

Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top