Magento Forum

Error: Parent Role id ‘G5’ does not exist
 
enflammer
Jr. Member
 
Total Posts:  1
Joined:  2008-07-21
 

I was managing categories, upon saving I received this error message:

There has been an error processing your request.

Parent Role id ‘G5’ does not exist
Trace:
#0 /home/erabox/public_html/lib/Zend/Acl.php(124): Zend_Acl_Role_Registry->add(Object(Mage_Admin_Model_Acl_Role_User), ‘G5’)
#1 /home/erabox/public_html/app/code/core/Mage/Admin/Model/Mysql4/Acl.php(100): Zend_Acl->addRole(Object(Mage_Admin_Model_Acl_Role_User), ‘G5’)
#2 /home/erabox/public_html/app/code/core/Mage/Admin/Model/Mysql4/Acl.php(69): Mage_Admin_Model_Mysql4_Acl->loadRoles(Object(Mage_Admin_Model_Acl), Array)
#3 /home/erabox/public_html/app/code/core/Mage/Admin/Model/Session.php(93): Mage_Admin_Model_Mysql4_Acl->loadAcl()
#4 /home/erabox/public_html/app/code/core/Mage/Admin/Model/Observer.php(69): Mage_Admin_Model_Session->refreshAcl()
#5 /home/erabox/public_html/app/code/core/Mage/Core/Model/App.php(1096): Mage_Admin_Model_Observer->actionPreDispatchAdmin(Object(Varien_Event_Observer))
#6 /home/erabox/public_html/app/Mage.php(271): Mage_Core_Model_App->dispatchEvent(’controller_acti...’, Array)
#7 /home/erabox/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(385): Mage::dispatchEvent(’controller_acti...’, Array)
#8 /home/erabox/public_html/app/code/core/Mage/Adminhtml/Controller/Action.php(117): Mage_Core_Controller_Varien_Action->preDispatch()
#9 /home/erabox/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(336): Mage_Adminhtml_Controller_Action->preDispatch()
#10 /home/erabox/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(137): Mage_Core_Controller_Varien_Action->dispatch(’index’)
#11 /home/erabox/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(168): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#12 /home/erabox/public_html/app/Mage.php(420): Mage_Core_Controller_Varien_Front->dispatch()
#13 /home/erabox/public_html/index.php(46): Mage::run()
#14 {main}

Now I have that error message everytime I login into the admin page, without any access to the admin menu at all. How can I fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dekard
Sr. Member
 
Total Posts:  80
Joined:  2008-06-03
 

bump, I’m having a similiar issue. How did you resolve this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
patbrumfield
Jr. Member
 
Total Posts:  20
Joined:  2008-06-11
 

yes, i would also like to know the answer to this question!

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dekard
Sr. Member
 
Total Posts:  80
Joined:  2008-06-03
 

I found a solution, check this thread.

http://www.magentocommerce.com/boards/viewthread/15556/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top