Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

php.ini solution
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

I am having issues with my server rewriting the URLs using the htaccess file.  The issue was figured out by Moshe (thanks) and I contacted my host (Netfirms) and they said the issue could be fixed by using a PHP.ini file.

This is what the links in the source code come out to be...

<link rel="icon" href="http://snakeriverbrewing.com/magento/index.php/favicon.ico" type="image/x-icon"/>
<link rel="shortcut icon” href="http://snakeriverbrewing.com/magento/index.php/favicon.ico" type="image/x-icon"/>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/prototype/prototype.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/prototype/validation.js" ></script>

<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/js/translate.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/varien/js.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/varien/form.js" ></script>
<link rel="stylesheet" href="http://snakeriverbrewing.com/magento/index.php/skin/install/default/default/css/styles.css" type="text/css" media="all"/>

Here is what Moshe related to me...

Ok, the problem is that instead of having ‘/magento/install’ in $_SERVER[’REQUEST_URI’] you have ‘/magento/index.php’ for some reason. There’s nowhere in $_SERVER nor $_ENV any notice of the original URL.

I’m trying to workaround using [E=REQUEST_URI:$1] flag for RewriteRule but unsuccessfully so far.

Can anyone let me know what needs to go into the PHP.ini file and where to place it on the server to fix the issue.

Any and all help is greatly appreciated as I am more of a designer than a developer and readily admit my short comings as a code guy.

Thanks again in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
Munchie75
Jr. Member
 
Total Posts:  3
Joined:  2008-07-10
 

Ok, i’m with netfirms as well, and the solution to the problem is that currently (july 2008) netfirms do not have the pdo_mysql component on there servers.

this is an integral part of the system which magento requires, and really speeds up the database and the rest of the site.

The service team are pushing to get pdo_mysql onto their servers, but it is not currently scheduled.

I hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
nftesting
Jr. Member
 
Total Posts:  1
Joined:  2008-08-14
 

This is just an FYI:

Netfirms now has support for pdo_mysql and have confirmed that magento does work and can be installed without any problems including the full use of htaccess modrewrite.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top