Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Categories and products not updating (completely)
 
foodstor
Jr. Member
 
Total Posts:  20
Joined:  2007-11-06
 

First, I went about trying to delete the other languages (French, German), from the admin, but discovered that feature still has a bug, so I went about trying to do it manually through the database.  I went into the database and removed those two related entries from the database tables core_website and core_store as well as removed those 2 languages from the languages table.  I also remove all products and category fields where the scope matched those 2 languages.

The problem is now when I go to update a category or product, it does not really update for me when I go look at the front end website. 

When I look at the database, I can see that the category is listed twice, once for the store_id of 0, and the other for 1.  The 0 is for the “Default” store, and the 1 for the “English Store” Only the field with the category of Default store is updating.

I saw another thread somewhere that explained how to remove extra stores manually, but cannot find it any more; but more importantly, hwo can I fix this?

--------------------------------------------------------
Here is what I have in my core_website table:

0     default      Default           0     1
1     base         Main Website     0     1

--------------------------------------------------------
Here is my core_store table:

0    default      en        0        Default              0     1
1    base         en        1        English Store         0     1

--------------------------------------------------------
Here is a sample from my catalog_category_entity_varchar table (can see the problem in the 3rd and 4 row):

59      9      479      0      12      digital-cameras
60      9      479      1      12      digital
-cameras
61      9      111      0      13      Weddings  
(after renaming the category)
62      9      111      1      13      Electronics  (before renaming)
 
Magento Community Magento Community
Magento Community
Magento Community
 
foodstor
Jr. Member
 
Total Posts:  20
Joined:  2007-11-06
 

So, I reinstalled the whole thing.  Database, files, etc… thinking that would solve it.  I left the default stores there (french, german, english).

however, the problem still exists.  the database shows 2 records for each category as I explained in my previous post, and the menus on the site front end do not update cause the database is only updating one of the two fields.

 
Magento Community Magento Community
Magento Community
Magento Community
 
foodstor
Jr. Member
 
Total Posts:  20
Joined:  2007-11-06
 

Hello?

Maybe I should look for another host other than my own server.  What is the easiest/most reliable host to setup Magento on?

 
Magento Community Magento Community
Magento Community
Magento Community
 
RoyRubin
Enthusiast
 
Avatar
Total Posts:  968
Joined:  2007-08-07
Los Angeles, CA
 

This is a good start

http://www.magentocommerce.com/wiki/general/magento-web-hosting

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top