Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Importing a modified export file
 
stevedaly
Jr. Member
 
Total Posts:  4
Joined:  2008-08-07
Cincinnati, OH
 

I have exported our catalog to make some batch updates.  I used the default all product export.  I edited the CSV file in Excel.  I attempted to upload the file, but the import says 0 rows found.

The CSV file looks good in a text editor.  I have imported other CSV files without problems.  The difference is that the new import has attribute sets/attributes defined on products.

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1093
Joined:  2008-07-16
London, United Kingdom
 

hey steve,

you have created the attributes sets in magento already right?

you have assigned some fields to these attributes sets in magento?

hth
brendan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fibo
Sr. Member
 
Avatar
Total Posts:  107
Joined:  2008-06-25
Marseille, France
 

When trying this export / edit / import scheme.... I met strong problem when using Excel, but not using Open-Office!!!

Just a background note: I am French and thus using a French version of Excel.
-->> when exporting to csv, it in fact separated by ; instead of ,
That would not be a big deal, EXCEPT that since not all fields are enclosed within “… there is no easy way to make the manual conversion (did I say that some products descriptions have , in their text?).

SOLUTION (nothing to be proud of, but at least it works!)
- save the excel file as xls
- open it within open-office
- export it to csv
And now it is fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Scott
Guru
 
Avatar
Total Posts:  333
Joined:  2007-08-31
Northwest Ohio
 

common problem with excel… if you look at the options when you save, you’ll probably see some configurable settings to make up for these undesired results, but I cannot confirm any specific version, other than that it’s not the default CSV option that I have the best results with.

 
Magento Community Magento Community
Magento Community
Magento Community
 
magentomatt
Member
 
Total Posts:  37
Joined:  2008-08-08
 

Steve are you on a mac OS?  This is probably a stupid answer and you’ve already figured it out, but it took me three days to figure out that I needed to save the .csv as a ‘Windows .csv’.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bowen
Member
 
Avatar
Total Posts:  37
Joined:  2008-04-09
 

magentomatt, YOU ARE A LIFESAVER!  cheese

I’ve been screwing around with this for 3 days .....saving to windows csv was the trick!  XML worked pretty well except for the fact that it converted all of my html tags.  Now the CSV works and keeps all of my formatting, thank you!

EDIT:  This works much better if you have the iWork “Numbers”

Bowen - 28 August 2008 05:54 AM

Solution for MAC users:

1) export as CSV and remove the from “Enclose Values In” (this may or may not matter)
2) open your CSV in the iWork application: Numbers (DO NOT USE EXCEL)
3) export as CSV Unicode (UTF-8) (thank you Andreas!)
4) import as CSV
5) smile as your products finally process with ease cheese


I was getting the same error and it definitely has to do with proper encoding and characters.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jbarkat
Jr. Member
 
Total Posts:  15
Joined:  2007-11-16
 

I had problems importing product files into magento earlier. I basically paid magento $500 to find out what you learned. When I would upload product files I noticed that a handful of SKUs (out of thousands) would take and the others would not get uploaded. I was told by magento to get a text editor and make sure I save the CSV file in UTF-8 format. I did and it worked like a charm. I’m using UltraEdit on a PC.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fibo
Sr. Member
 
Avatar
Total Posts:  107
Joined:  2008-06-25
Marseille, France
 
jbarkat - 07 September 2008 09:47 PM

...I was told by magento to get a text editor and make sure I save the CSV file in UTF-8 format. I did and it worked like a charm. I’m using UltraEdit on a PC.

I am a visceral fan of Ultra-Edit, which for $50 saves me lots of trouble with UTF-8 and other end-of-line problems!
This UTF-8 problem is very important for Magento, and more specifically the csv, css and xml files....

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top