Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Lost connection to Magento Error Page…. 
 
ISYL
Jr. Member
 
Total Posts:  12
Joined:  2008-08-01
 

Hi folks. We’ve been going through this board all day, and could not find an answer, so here goes…

If you go to a page that does not exist on our site, ie. (http://isyl.com/shop2/doesnotexist), the default Magento (our version)
error page (http://www.isyl.com/shop2/not-found) is not seen. Here is some info about our setup:

Please be aware that Cache is disabled so the site may be slow

The attached photos are of our error identifier page and our web configuration page. Below is our .HTACCESS File. What can we do to get
the website to Rewrite errors to our error page? Thanks

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php
    #AddHandler fcgid-script .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 64M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off
    
###########################################
# turn off compatibility with PHP4 when dealing with objects
    
    
php_flag zend.ze1_compatibility_mode Off
    
</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    #SetOutputFilter DEFLATE

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /shop2/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none
Image Attachments
isyl01.jpgisyl02.jpgisyl03.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
ISYL
Jr. Member
 
Total Posts:  12
Joined:  2008-08-01
 

Also, we lost the connection after upgrading to the latest version of Magento (through Magento Connect Manager).
We have also tried:

Reinstalling Magento Core Modules
Disabling Web Server ReWrites
Renaming the noRoute page as no-route
At GoDaddy (our host), using our homepage for all 404 Errors

These did not work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ISYL
Jr. Member
 
Total Posts:  12
Joined:  2008-08-01
 

OK, we see that now our GoDaddy Custom 404 Error Page works, but only on the main domain, not for the Magento store. If a user types in an incorrect file or folder anywhere outside of the Magento store folder, the user is sent to an error page designated by us (the one inside the Magento/404 folder).

Also, with the Magento .htaccess file removed, all errors go to the folder we designated at GoDaddy. With the .htaccess file replaced, errors within our Magento store go to the error page linked to in our above post. So, what do we need to do to our .htaccess to make it work properly?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ISYL
Jr. Member
 
Total Posts:  12
Joined:  2008-08-01
 

We now have the GoDaddy 404 Error page working again. We had to make sure that at GoDaddy’s 404 Error Page Editor, after selecting to use a ‘Custom’ page, we had to use a direct link to the folders and the file within our site (not a link to a virtual folder).

But all of this is still outside of our Magento folder. We still are unable to get Magento to send a user to Magento’s 404 Error page when they type in a bad link to a page or product within Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
metronome
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2010-01-20
Melbourne, Australia
 

I’m getting the same problem, not luck getting it to work so far. Bugger.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ellen_h
Jr. Member
 
Total Posts:  11
Joined:  2010-10-27
 

I’ve got this same problem.  Did you find a fix?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top