Magento Forum

   
Page 2 of 2
htaccess issue
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

The problem is ‘index.php’ that you have in RewriteRule lines. You shouldn’t need it.

Maybe there’s some specific distinction in apache/php setup that prevents correct environment parsing..

I could take a look if you would PM me temporary shell account info.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Ok, the problem is that instead of having ‘/magento/install’ in $_SERVER[’REQUEST_URI’] you have ‘/magento/index.php’ for some reason. There’s nowhere in $_SERVER nor $_ENV any notice of the original URL.

I’m trying to workaround using [E=REQUEST_URI:$1] flag for RewriteRule but unsuccessfully so far.

Maybe someone familiar with FreeBSD could shed some light here?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

I’ve tried to get help on irc://freenode/#apache but not much luck, they need access to rewritelog. I would try asking your hoster for help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

Not knowing much about htaccess files etc… Does the info at the following link shed any light?  http://support.netfirms.com/idx.php/0/696/article/How-do-I-configure-URL-forwarding-using-modrewrite.html

I am not sure how different servers react and are configured but maybe you can see something in that help doc direct from my hosting company that may be server specific… I owe you big time.

Thanks again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Couldn’t find anything specific to the host, all the examples are standard .htaccess rules.

I think the problem is with apache configuration on this host.

The Apache manual clearly states: “REQUEST_URI: The resource requested in the HTTP request line.”
Which means it should be “/magento/install”. On your server it is “/magento/index.php”. Ask your hoster why, and how to fix this.

I do not see how i can help more than that..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

I’ve made a test page to show the problem: http://snakeriverbrewing.com/test/blah

$_SERVER[’REQUEST_URI’] should be “/test/blah”, while it’s “/test/index.php”

 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

So when I click on the link it shaould go to “test/blah” or “/test/index.php”?  I have submitted a trouble ticket to the hosting company to see what they can do…

 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

I got a response from the hosting company and they said it can be fixed using a php.ini file…

ANy ideas based on that info?

The shell access I gave you is still valid or if you need something else I can get it to you.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
euchrid
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2008-04-06
 

I am having a similar problem. I get a JS error on every page for both frontend and backend. Most seem related to varien JS. I did notice during install that all forms and URL’s were using index.php . Could this have been interpreted as part of the root?

http://www.euchridcreative.com/magento/

 
Magento Community Magento Community
Magento Community
Magento Community
 
de5ign
Jr. Member
 
Total Posts:  1
Joined:  2008-11-11
 

Hi I’ve just spent 3 days trying to install Magento. I’ve just about given up. Looks like problem is the .htaccess too. I get a 500 error code. If I delete the file I can get to the installer but the continue button isn’t active. I had a look at the error logs for my host and therysay the .htaccess file isn’t allowed to be uploaded to it’s current location. It’s in the htdocs file with everything else.

I’ve contacted the host but I doubt I’ll get any help. It’s a shame because this did look like a great package. also I have no intention of messing around with the code in .htaccess file or trying to change settings. If it won’t work I’ll just find something that does. :-(

Update: back to Zencart for now. Maybe I’ll feel like trying again oneday.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gimk
Jr. Member
 
Total Posts:  1
Joined:  2012-05-19
 

Well, maybe it’s too late, but… It appears that if the options directive was configured then it’s necessary to set up the directory directive too.
This implies access to the Apache configuration files.
If this is not the case, we can simply comment the line “Options +FollowSymLinks”, considering that this directive is by default “Options All” as states the Apache documentation. (http://httpd.apache.org/docs/2.2/mod/core.html#options).

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 2 of 2