Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
htaccess issue
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

I have been trying every possible htaccess configuration that has been shown in this forum...some give me the 500 error other 400 error… and finally I get the INstall screen but the continue button doesn’t become active after checking the terms box…

I know there are other posts related to this problem but there doesn’t seem to be a definative answer…

I am hosted on Netfirms and runnin PHP5 and all the other configs are as they should be.

The htaccess file that at least gets me to the Install Screen is as follows…

DirectoryIndex index.php

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots|var\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

RewriteEngine on

RewriteBase /
RewriteRule !\.(js|ico|txt|gif|jpg|png|css)$ index.php

RewriteEngine on

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_URI} !^/var/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php
ReWriteBase /

I have been trying to install this thing for 2 weeks now and the only thing keeping me going is the great feedback people that have been successful in installing are giving this solution. 

Please help me and the other people present and future that are having this issue.  If yo need more info I will be happy to provide it.

THanks in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ibn Saeed
Jr. Member
 
Total Posts:  25
Joined:  2007-09-01
UAE
 

I am also having the same problem on my Localhost which im running through XAMPP on Windows.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

You shouldn’t have to keep specifying the rewrite base and enabling the rewrite engine. You can remove a lot of what you had, because the !-f, !-d, and !-l directives will not send the request to index.php if the file (f), directory (d), or symbolic link (l) exists, so I see no reason why all that stuff was in there.

Here is the .htaccess I am using and it works fine:

RewriteEngine On

RewriteBase 
/magento/

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l
RewriteRule 
index.php [L]

NOTE: You should also consider adding this to the top of your .htaccess file, some hosts do not have this enabled by default, which could lead to a 500 error:

Options +FollowSymLinks
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@Crucial: the reason for

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_URI} !^/var/
is to prevent loading index.php for any missing image, javascript, stylesheet or temporary file.
We prefer to receive 404 than to make the server work harder than it needs to.
 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

All this advice has been given in past posts and nothing seems to make the continue button active.

Please see the URL http://snakeriverbrewing.com/magento/install/

I am at my wits end.  Is there anything outside of the htaccess file that may casue this issue to conitnue to happen?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@formermember: Could you please paste your .htaccess and also link to script with phpinfo() on your server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@formermember; sorry, overlooked it on the top..

i think one of the problems is here:

RewriteRule ^(.*)$ /magento/index.php/$1 [L]

Could you restore the original .htaccess and we will start from there?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
Moshe - 10 November 2007 10:45 AM

is to prevent loading index.php for any missing image, javascript, stylesheet or temporary file.
We prefer to receive 404 than to make the server work harder than it needs to.

Ah, good point smile Thanks, will update our article and htaccess.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ibn Saeed
Jr. Member
 
Total Posts:  25
Joined:  2007-09-01
UAE
 

Here is my .htaccess

# php_flag magic_quotes_gpc off
# php_flag short_open_tag on

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ibn Saeed
Jr. Member
 
Total Posts:  25
Joined:  2007-09-01
UAE
 

Alright, I got it to work.

If you are getting 500 Error messages

Here are the steps I used:

CONFIGURE APACHE

1). Open the file C:\xampp\apahce\conf\httpd.conf

2). Find the line containing “#LoadModule rewrite_module modules/mod_rewrite.so” and remove the “#” so it looks
like “LoadModule rewrite_module modules/mod_rewrite.so”

3). Save your changes and close the file.

Because you made changes to the Apache configuration you will need to restart Apache. Do this through the
XAMPP Control Panel by pressing stop and then start buttons next to Apache.

CONFIGURE PHP
Open ”php.ini ”and remove the “;” from the beginning of the following lines:

1). ;extension=php_mcrypt.dll

2). ;extension=php_mcrypt_filter.dll

3). ;extension=php_mhash.dll

4). ;extension=php_curl.dll

Once finished removing the semicolon from each line save your file.

FINAL STEP

RESTART AND TEST APACHE / PHP

Run the Installer

 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

original htaccess fille is as follows

<IfModule mod_php5.c>
php_flag magic_quotes_gpc off
php_flag short_open_tag on
</IfModule>

DirectoryIndex index.php

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php

error result

Not Found
The requested URL /snakeriverbrewing.com/w0700/d12/s26/b028351e/www/snakeriverbrewing.com/magento/index.php was not found on this server.

now I can’t even get to the install page.

Let the games begin:)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@formermember: ok, now, if i could deduct correctly that your relative path is /magento, try ONE of the following:

1. add RewriteBase /magento

2. replace

RewriteRule .* index.php
with
RewriteRule .* /magento/index.php
 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

Error

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

* This problem can sometimes be caused by disabling or refusing to accept
cookies

FYI cookes are enabled

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Then my guess wasn’t correct. could you please paste your web root path and root for your magento installation?

 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

web root

/www/snankeriverbrewing.com/

magenta toot

/www/snankeriverbrewing.com/magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
formermember
Jr. Member
 
Total Posts:  10
Joined:  2007-11-10
 

Looking at the source of the install page… are the paths shown correct?  If not waht could I do to fix it?

SOURCE…

<link rel="icon" href="http://snakeriverbrewing.com/magento/index.php/favicon.ico" type="image/x-icon"/>
<link rel="shortcut icon” href="http://snakeriverbrewing.com/magento/index.php/favicon.ico" type="image/x-icon"/>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/prototype/prototype.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/prototype/validation.js" ></script>

<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/js/translate.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/varien/js.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/varien/form.js" ></script>
<link rel="stylesheet" href="http://snakeriverbrewing.com/magento/index.php/skin/install/default/default/css/styles.css" type="text/css" media="all"/>
<!--[if IE]><link rel="stylesheet" href="http://snakeriverbrewing.com/magento/index.php/skin/install/default/default/css/iestyles.css" type="text/css" media="all"/><![endif]-->
<!--[if lt IE 7]>
<link rel="stylesheet" href="http://snakeriverbrewing.com/magento/index.php/skin/install/default/default/css/ie7minus.css" type="text/css" media="all"/>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/lib/ds-sleight.js" ></script>
<script type="text/javascript\" src="http://snakeriverbrewing.com/magento/index.php/js/varien/iehover-fix.js" ></script>
<![endif]-->

<link rel="stylesheet" href="http://snakeriverbrewing.com/magento/index.php/skin/install/default/default/css/print.css" type="text/css" media="print" />

MY CURRENT htaccess

DirectoryIndex index.php

RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots|var\.txt)
RewriteRule ^(.*)$ /magento/index.php/$1 [L]

RewriteEngine on

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_URI} !^/var/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule ^(.*)$ /magento/index.php/$1 [L]
ReWriteBase /

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2