Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Homepage is Displayed When Viewing Product Details
 
Trevor Ochocki
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-07-17
Corvallis, Oregon, USA
 

As I was getting setup to use my own SSL certificate with my host, I upgraded to Magento 1.1.1. What was working well before has now turned into a bit of an annoyance. First, using thread http://www.magentocommerce.com/boards/viewthread/4320/ as a guide, I had changed ‘HTTPS’ to ‘HTTP_X_FORWARDED_SERVER’ in certain files to make Magento functional again. I am not sure if I had to do this because of version 1.1.1 or my new SSL certificate. Everything was functioning well with Magento 1.0 and the shared certificate. I would like to avoid modifying the Magento core so any tips on this would help.

That being said, it is working, except for when I try to view a product’s details, the homepage gets displayed instead. The product URL is correct but I see the homepage instead of product details. Similarly, I also get redirected to the homepage after clicking a message ‘Mark as Read’ link in the admin panel.

Not sure if it is my SSL certificate setup, rewrites, redirects, etc., so any advice would be greatly appreciated. I also had my web host look into the matter and they are seeking more information on Magento themselves. Thanks.

P.S. I see version 1.1.2 is available. I will upgrade and report back if my situation has improved.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Trevor Ochocki
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-07-17
Corvallis, Oregon, USA
 

...it is working, except for when I try to view a product’s details, the homepage gets displayed instead. The product URL is correct but I see the homepage instead of product details. Similarly, I also get redirected to the homepage after clicking a message ‘Mark as Read’ link in the admin panel.

I am still unable to resolve this issue. See attached screenshot (notice URL and page title) or, while it lasts, the link itself. I am currently using version 1.0.19870.4 with rewrites on, and have experienced the same thing in version 1.1. I have noticed others encountering similar experiences. Anyone out there have any ideas?

Image Attachments
Screen01.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Trevor Ochocki
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-07-17
Corvallis, Oregon, USA
 

The following URL renders the product view correctly:

http://staging.floraelan.com/magento/catalog/product/view/id/120/s/ink-eater-krylon-bombear-destroyed-tee/category/18/

While the ‘proper’ URL continues to render the homepage:

http://staging.floraelan.com/magento/apparel/shirts/ink-eater-krylon-bombear-destroyed-tee-1.html

I activated the ‘Code Profiler’ which can bee seen at the bottom of each linked page above or in the attached screenshots. It looks like Magento is taking a wrong turn somewhere around ‘ctrl/dispatch’. Does anyone know how Magento determines what pages are ‘dispatched’?

Image Attachments
This Product View URL Actually Renders The Product View.pngThis Product View URL Renders Homepage.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Trevor Ochocki
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-07-17
Corvallis, Oregon, USA
 

My issue has been resolved! My hosting company noticed that:

Apache was trying to serve the file directly (because the URL ended in .html) without checking that the file actually exists (which it doesn’t in this case).

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top