Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
why it always says"Coupon code “10off” is not valid”. 
 
charleslee
Jr. Member
 
Total Posts:  15
Joined:  2008-07-25
 

i created a Coupon code named"10ff" and applied it to a certain product...but after i entered the cart page and enter this code,it will report that as the title.

 
Magento Community Magento Community
Magento Community
Magento Community
 
charleslee
Jr. Member
 
Total Posts:  15
Joined:  2008-07-25
 

any body to help me ? thanks in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

my coupon code does not work either, maybe its the combo of letters and numbers??

 
Magento Community Magento Community
Magento Community
Magento Community
 
JenniferAslan
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-08-20
Pacific Northwest
 

Mine doesn’t work either. We are running version 1.1.6. If I have conditions in my cart that apply another automatic discount and I try to apply my coupon code, it acts like it’s doing it, but it overrides the other shopping cart rule (even though they’re all set to not stop rule processing). If the things in the cart have no other shopping cart rules applied and I try to apply my coupon code, it tells me the coupon code is invalid. I have tried several different combinations of letters and numbers, to no avail. Is this a bug?

 
Magento Community Magento Community
Magento Community
Magento Community
 
FinleyMedia
Jr. Member
 
Total Posts:  8
Joined:  2008-05-13
 

Has this been answered yet? I have a coupon that applies to a specific product and keep getting Coupon code “WECAL01” is not valid.

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilA
Moderator
 
Avatar
Total Posts:  1372
Joined:  2007-09-17
Blue Mountains, Oz
 

I’m pretty new to Megento, but I’ve got the coupons working in my pre-release store OK.
Caveat: I don’t have any other shopping cart rules set up at the moment.

Things I had to check for:
* Correct dates for start and expiry
* Setting (highlighting) the corrrect customer groups for the coupon
* Setting it ‘active’ (duh!).

I left Conditions set as: “If ALL of these conditions are TRUE :”
And I set ‘Stop further rules processing’ to YES

Then I set up half a dozen or so coupons and checked that they worked OK.

I realise that all those conditions may not suit all users, but it’s a starting point to work from.

Hope that helps.

Neil

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Sunday Paper
Sr. Member
 
Total Posts:  202
Joined:  2008-08-06
 

Something else to look out for: Our coupon codes invariably corrupt themselves over a very short time, so if you check a code and it isn’t working, go back into the code and see if the Conditions are all still just as you set them on both the second and third pages of editing. For whatever reason, Magento swaps them around (on our installation), pulling in and repeating random criteria from OTHER coupon codes, thereby rendering each of ours useless.

Since we corrected the date formats in Magento to allow the New Products to work correctly, we also have a problem with the dates swapping their own Month and Day values in the expiration dates, which also renders them invalid.

These issues could be a bit beyond where you are now if you haven’t got them working from the outset yet, but they’re something to keep in mind and look out for in future rough coupon-times.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrewc
Jr. Member
 
Total Posts:  13
Joined:  2008-08-21
 

Also had a issue with INVALID Coupon.

I would type in the coupon code then submit it, the amount would be deducted but I would get the INVALID coupon error message.

It seems that the Error message is case sensitive.
So make sure you use the correct case when entering the coupon (same as the backend)

Works for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
viditech
Jr. Member
 
Total Posts:  7
Joined:  2008-08-27
 

We were having the same problem with PRODUCT SPECIFIC coupons, but found an answer…

For some reason, the SKUs require alphanumeric digits for the conditions and we only had numbers in ours. Do one of the following:

- Add an x in front of your SKUs (i.e. x0849873)
- Create a different condition instead of SKU, such as product name or description.  (However if the product name changes, you will have to change the coupon conditions as well.)

Hope this helps!

 
Magento Community Magento Community
Magento Community
Magento Community
 
quirkybird
Member
 
Avatar
Total Posts:  35
Joined:  2008-09-23
 

We’re having the same issue, however there are no rules set up and the only people that are able to recreate the error are customers. We’ve checked browsers, user error, and upgraded...the holy trinity of error fixing. Has anyone come up with anything on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
quirkybird
Member
 
Avatar
Total Posts:  35
Joined:  2008-09-23
 

So on receipt of more data, we’ve got a new development - the error is occuring only when someone is logged in. There are some anomalies so we’re trying to nail down the common denominator. The coupons are all set for all users to be able to apply, there are high limits on number of uses etc. We have three codes that are virtually the same, set up exactly the same, but two of them won’t work and one will.

We’re on version 1.2.1.2 and it’s a cross browser issue.

Anyone encounter this or have any insight or ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jarhody
Jr. Member
 
Total Posts:  20
Joined:  2009-03-10
 
viditech - 23 January 2009 06:07 AM

We were having the same problem with PRODUCT SPECIFIC coupons, but found an answer…

For some reason, the SKUs require alphanumeric digits for the conditions and we only had numbers in ours. Do one of the following:

Thanks for the help...I get the same result.

This seems like something that should be fixed in an update. Many of our SKU’s are only alpha or numeric. Seems like a hack for us to change our SKU numbers!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jarhody
Jr. Member
 
Total Posts:  20
Joined:  2009-03-10
 

I got it to work based on SKU that is either alpha or just numeric.

On the action tab at the bottom...only cart items....

If ANY of these conditions are TRUE :

* SKU is SC911P Apply
* SKU is HEALING Apply

***Need to separate the products on seperate lines.**** Seems to work!

Adios!

 
Magento Community Magento Community
Magento Community
Magento Community
 
quirkybird
Member
 
Avatar
Total Posts:  35
Joined:  2008-09-23
 

Ours weren’t using sku’s in the rules, we figured out that it was related to the start dates on the coupons resetting to be for the year 2010. From the forums, we discovered that you must set up a cron for the rules to work properly. That fixed all coupon issues for us! My question is, why isn’t this done by Varien on install? If you’re using catalog price rules, you have to have a cron set up. What store owner isn’t going to use freaking coupons?! I mean, it seems like a major oversight. I <3 magento, but some of this stuff is ridiculous. Anyhow, here’s the cron thread:
http://www.magentocommerce.com/boards/viewthread/16704/

Another thing that I’ve read a lot about is server time. Make sure that in your system > configuration you have your time zone set to the same as the server. This eliminated some complaints.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Argon2000
Member
 
Total Posts:  38
Joined:  2009-02-02
 

I do have cron set up but none of the rules are actually working for me it just always says not a valid code or ignores anything else suggestions or solutions would be appreciated

 
Magento Community Magento Community
Magento Community
Magento Community
 
BruceM
Jr. Member
 
Total Posts:  16
Joined:  2008-11-02
 

Pretty simple solution for me, thank god.

I got the “is not valid” error as well in testing. But when I logged on as a customer it worked. So I checked the Customer Group settings in Shopping Cart Price Rules and sure enough I need to select “Not Logged On” as well as “General”.

Yep not enough coffee…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2