Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Attribute Labels are not translated in Frontend View. Does any workaround exists? 
 
tackmann
Jr. Member
 
Total Posts:  13
Joined:  2008-05-31
 

After customizing the new 1.1.2 release of Magento for multiple languages in different frontend stores I only can see the default attribute labels under ‘Additional Information’ in product view as well as in the ‘Shop By’ filter navigation. I am using the default theme but a test run with modern theme installed showed up the same bug in label handling. On the Compare Products page everything works fine if you use the default theme. Even with the modern theme I could get the right labels showing up on the compare products page (through modifiing ../template/catalog/product/compare/list.phtml Line 72 to <td class="label"><?php echo $this->__($_attribute->getFrontendLabel()) ?></td>. But this will of course not work for the code in ../template/catalog/product/view/attributes.phtml (calling function in Attributes.php from core/mage). This issue was just sparely documented for other releases. And it looks as if there is no solution for it yet. Does anyone know if there is a workaround for that issue? I would like to get it working at least for two languages within the next week. Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
StockMania
Member
 
Avatar
Total Posts:  56
Joined:  2008-08-04
 

Hello

Same exact problem. I’d be happy to know the solution aswell

Regards
Max

 
Magento Community Magento Community
Magento Community
Magento Community
 
tackmann
Jr. Member
 
Total Posts:  13
Joined:  2008-05-31
 

Found a solution! See my new post:

http://www.magentocommerce.com/boards/viewthread/15376/

 
Magento Community Magento Community
Magento Community
Magento Community
 
StockMania
Member
 
Avatar
Total Posts:  56
Joined:  2008-08-04
 

Tackmann ! you are the best !!

It works great, i applied it right away.

Thank you.

One more bug, i can’t get the cache to refresh correctly, the catalog rewrites and layered navigation indices.

Everytime I try, time out, and on the site, all layered indices are just gone. I got 3000 products listed.

I can’t seem to find a solution anywhere.

maybe you have an idea.

thank you
Maxim

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top