Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Redirection when installing
 
Simkonstar
Jr. Member
 
Total Posts:  1
Joined:  2010-03-12
 

Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies.

i have cookies enabled, and i have installed the sample data just fine. What could have gone wrong…

 
Magento Community Magento Community
Magento Community
Magento Community
 
snowman58
Member
 
Total Posts:  54
Joined:  2009-04-09
 

Ditto - I have the same problem.

I was able to make an initial installation, but when I tried to reinstall I started getting this error.

Dropped the DB and re created it.

Emptied the browser history & cookies.

Emptied the Magento directories and recopied files.

Still have the problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
My2cents
Jr. Member
 
Total Posts:  30
Joined:  2009-03-11
 

did you check permissions on the index page? it needs to be 644…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Webdevoc
Jr. Member
 
Total Posts:  3
Joined:  2010-01-04
 

This issue seems to be very common but there is no documentation about it. Sometimes the help provided by fellow developers is vague and far from being specific. Where is that index page? How can we resolve something like this when neither the Apache Log nor the Magento Log are recording any entries related to the multiple redirection problem?

Regarding the Installation Guide, it is so basic that 90% of things are assumed. A real installation guide should be detailed and specific covering AT LEAST the most common issues. That installation guide should be renamed as “Installing Magento in Wonderland”.

SOLUTION

Considering that you are trying to install Magento on your local server, in other words, no Godaddy, 1and1, etc:

When you are at the “Configuration” step, for the database host, replace “localhost” by 127.0.0.1, and for the default store, both http and https, DO NOT enter anything after the forward slash (/) on the default base path field.

The “Skip URL Validation” option should be unchecked.

Click on “Continue” and you should see the screen saying: “YOU’RE ALL SET”.

The backend interface is available at https://www-dot-yourdomain-dot-com/admin

 
Magento Community Magento Community
Magento Community
Magento Community
 
snowman58
Member
 
Total Posts:  54
Joined:  2009-04-09
 

I was able to solve this problem by

1) removing the magento DB from MySQL and recreating it
2) totally cleaning out the store root directory and reinstall
3) deleting cookies and cached files from browser

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top