Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

problemi con magento connect e 1.1.2
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

ciao a tutti..

stavo provando ad aggiornare il mio magento alla 1.1.2 via magento connect… ma clicckando su check updates non mi mostra nulla…

mentre stavo pacioccando mi ho provato ad installare anche il theme pack per iphone… e magicamente appena terminata l’installazione ho scoperto che mi aveva anche installato il Mage_Core_Modules 1.1.2 e dalla dashboard dell’admin mi segnala come versione installata la 1.1.2

mumble mumble.. non mi sembra che il mio magento connect funzioni bene.. qualcuno ha qualche idea....

adesso l’aggiornamento è tutto installato o me ne ha installato solo un pezzo???

grazie a tutti

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

devi aspettare la conferma, a volte ci mette una vita a mostrare qualcosa. A me è capitato così. Poi ogni tanto litiga con i permessi -.-

 
Magento Community Magento Community
Magento Community
Magento Community
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

dando check for updates la pagina si ricarica abbastanza in fretta, la barra di avanzamento arriva in fondo e il bottone da cliccare scompare.... non succede più nulla per un po’....
ho pensato anche io a qualcosa sui permessi...... su che file mi consigli di pacioccare??

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

non ne ho idea. Il magento connect l’ho utilizzato poche volte e certe volte ho dovuto dare tutti i permessi… siccome lavoro in locale non mi sono fatto tante seghe mentali.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiaraweb
Guru
 
Avatar
Total Posts:  721
Joined:  2008-03-21
Aviano ~ Italy
 

Ciao
prova a dare un 777 recursivo a tutta la cartella del magento e prova l’update, se vuoi ti posso mettere uno screenshot dei moduli che ho aggiornato io cosi controlli.

Io comunque di norma dopo aver fatto l’update sostituisco la cartella con quella nuova ufficiale, cioe’ uso l’upgrade per aggiornare il database e poi cambio la cartella del magento mettendoci quella che danno come latest.

Ho avuto diversi problemi dopo gli update soprattutto con i files xml e js!! (tipo menu admin coi bottoni nn cliccabili ecc)

 
Magento Community Magento Community
Magento Community
Magento Community
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

ops..
ho dato 777 a tutta la cartella download
e risultato..

http 500 - errore interno del server

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiaraweb
Guru
 
Avatar
Total Posts:  721
Joined:  2008-03-21
Aviano ~ Italy
 

Recursivo di tutta la cartella del magento non solo della downloader
Dal browser prova ad abilitare anche le spefifiche degli errori hhtp, e se hai abilitato il log vai a controllare i log e vedi nelle ultimi eventi cosa c’e’ scritto

 
Magento Community Magento Community
Magento Community
Magento Community
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

niente da fare ho provato a dare a tutta la cartella ma niente..

 
Magento Community Magento Community
Magento Community
Magento Community
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

allora sia in locale su mamp non mi fa partire il connect.. ho provato con l’1.1.1 con database aggiornato da quello vecchio ma niente, con una nuova installazione e database nuovo, ma niente… pensavo ad un bug della 1.1.1.... ho scaricato la 1.1.2 installata da nuovo ma mi da lo stesso errore…
in locale uso un test server Mamp (lavoro su mac) che mi da parecchi problemi… ho pensato fosse causa sua… ho provato tutte le configurazioni… ma niente… ho provato a cambiare permessi a tutto.. ma non è servito…
ho provato sul server remoto dove ho caricato un 1.1.1 ma non funziona nemmeno li.. e volevo evitare di rifare le modifiche apportate ai vari file per avere oggetti in home page… etc....

posto il log del server apache remoto… magari me lo sapete spiegare dove si incricca....

--.-.68.254 - - [07/Aug/2008:09:29:15 +0200] "GET /v1/downloader/ HTTP/1.1" 200 1448 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:16 +0200] "GET /v1/downloader/js/prototype.js HTTP/1.1" 200 22393 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:16 +0200] "GET /v1/downloader/skin/boxes.css HTTP/1.1" 200 2025 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:17 +0200] "GET /v1/downloader/skin/images/btn_bg.gif HTTP/1.1" 200 422 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:17 +0200] "GET /v1/downloader/skin/images/logo.gif HTTP/1.1" 200 4045 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:17 +0200] "GET /v1/downloader/skin/images/header_bg.gif HTTP/1.1" 200 562 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:19 +0200] "POST /v1/downloader/ HTTP/1.1" 302 496 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:19 +0200] "GET /v1/downloader/index.php?A=index&loggedin;HTTP/1.1" 200 2152 "http://www.wirelesshop.it/v1/downloader/" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:21 +0200] "GET /v1/downloader/index.php?A=empty HTTP/1.1" 200 817 "http://www.wirelesshop.it/v1/downloader/index.php?A=index&loggedin;" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:22 +0200] "GET /v1/downloader/skin/images/nav_bg.gif HTTP/1.1" 200 317 "http://www.wirelesshop.it/v1/downloader/index.php?A=index&loggedin;" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:23 +0200] "GET /v1/downloader/index.php?updates=yes&A;=index&loggedin;HTTP/1.1" 200 2088 "http://www.wirelesshop.it/v1/downloader/index.php?A=index&loggedin;" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
--.6.68.254 - - [07/Aug/2008:09:29:23 +0200] "GET /v1/downloader/index.php?A=empty HTTP/1.1" 200 817 "http://www.wirelesshop.it/v1/downloader/index.php?updates=yes&A;=index&loggedin;" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; it-it) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1"
66.249.73.46 - - [07/Aug/2008:09:30:01 +0200] "GET /magento/index.php/catalog/category/view/order/position/dir/desc/color/26/manufacturer/20/id/27/ HTTP/1.1" 200 7812 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"

ho tolto le prime due cifre al mio ip…

se volete curiosare l’indirizzo è http://www.wirelesshop.it/v1/

l’ultimo ip non è il mio… ho avuto lo sculo che mentre facevo le prove un google boot stava scansionando il sito?? se no cosa centra??

 
Magento Community Magento Community
Magento Community
Magento Community
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

sono andato a spulciare tra le cartelle per vedere dove fosse il problema
alla fine ho trovato che non avevo molti file in una cartella nascosta…
/downloader/pearlib/php/.registry/.channel.connect.magentocommerce.com_core/

tutta una serie di file .reg ....

ho provato ad andare sul server a sostituirlo… risultato adesso mi vede i file i i file da aggiornare, ma facendo partire l’update
nel frame mi da questo messaggio:

Exception caught:

Warningpopen() has been disabled for security reasons in /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/OS/Guess.php on line 247

Backtrace
:
#0 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/OS/Guess.php(247): mageCoreErrorHandler(2, 'popen() has bee...', '/home/zpqq18/do...', 247, Array)
#1 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/OS/Guess.php(159): OS_Guess->_detectGlibcVersion('/usr/bin/cpp /t...', 'r')
#2 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/OS/Guess.php(114): OS_Guess->parseSignature()
#3 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/PEAR/Dependency2.php(105): OS_Guess->OS_Guess(NULL)
#4 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/PEAR/Downloader.php(259): PEAR_Dependency2->PEAR_Dependency2()
#5 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/PEAR/Downloader.php(501): PEAR_Downloader->getDependency2Object(Object(PEAR_Config), Array, Array, 4)
#6 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/PEAR/Downloader.php(409): PEAR_Downloader->analyzeDependencies(Object(PEAR_Config), Array, Array, 4)
#7 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/PEAR/Command/Install.php(629): PEAR_Downloader->download(Array)
#8 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/pearlib/php/PEAR/Command/Common.php(285): PEAR_Command_Install->doInstall(Array)
#9 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/Maged/Pear.php(228): PEAR_Command_Common->run('upgrade', NULL, Array)
#10 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/Maged/Pear.php(295): Maged_Pear->run('upgrade', NULL, Array)
#11 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/Maged/Model/Pear.php(201): Maged_Pear->runHtmlConsole('upgrade', NULL, Array)
#12 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/Maged/Controller.php(113): Maged_Model_Pear->applyPackagesActions(Array)
#13 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/Maged/Controller.php(344): Maged_Controller->pearPackagesPostAction(Array)
#14 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/Maged/Controller.php(164): Maged_Controller->dispatch()
#15 /home/zpqq18/domains/wirelesshop.it/public_html/v1/downloader/index.php(29): Maged_Controller::run()
#16 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
i2p0
Sr. Member
 
Total Posts:  179
Joined:  2008-03-28
 

risolto chiedendo l’abilitazione dl modulo pear “popen” all’hoster…
avevo però ancora problemi di riferimenti alla directory del mio server locale..
cancellato il file pear.ini è andato tutto a posto…

se qualche anima pia che non ha avuto problemi mi posta uno screenshot del proprio connect così controllo che non si dimentichi qualche pezzo…

grazie

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top