Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP Extension “mysqli” must be loaded
 
my evil twin
Member
 
Total Posts:  34
Joined:  2007-08-31
Hamburg, Germany
 

Hello,

after uploading the files to my apache webserver, i get this error message
:
PHP Extension “mysqli” must be loaded

unfortunately, i am not the owner of this server, so i can not touch the php.ini or anything.
is this something, my hoster can fix? or can i enable this via ht.acess-file?

sorry, i don’t know anything about zend-components or anything like this, so forgive me my stupid questions smile

i am using php 5.

thanks in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
winans_fred
Sr. Member
 
Total Posts:  83
Joined:  2007-09-06
 

Ditto this problem.  I tried to tweak this in my current MySQL install (5.1) and can’t seem to handle it there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cage
Jr. Member
 
Total Posts:  3
Joined:  2007-10-04
 

Any advance on this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jorries
Member
 
Avatar
Total Posts:  56
Joined:  2007-10-07
 

Try to upgrade to latest version of mysql, apache, and php

I had several module errors after updating to php5 then updates apache httpd and everything was fixed automatically.
Or check php.ini most times /etc/php.ini on linux and uncomment the ;extension lines with the mysqli thing in it, that enables the module, restart apache,
perhaps work

just some quick ideas,
had 2 days trying to upgrade php5 on my VPS my hoster told me this could not be done,
but persistant and got all working very neatly rasberry
without breaking plesk!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bernhard Huber
Jr. Member
 
Avatar
Total Posts:  28
Joined:  2007-10-03
Warsaw Poland
 

Contact your hoster ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Al~Capone
Jr. Member
 
Total Posts:  3
Joined:  2007-12-30
 

i have uncomment that line but it still didn’t work. The server also has been restarted as well. Why is this problem still persist? When check the php info, the enabled extension is not shown in the info page...Somebody help me…

 
Magento Community Magento Community
Magento Community
Magento Community
 
lkbryant
Member
 
Avatar
Total Posts:  60
Joined:  2007-09-03
 

check your phpinfo() and see if you have something like this in the configure command
‘--with-mysqli=/usr/bin/mysql_config’

if its not, then and if possible, you need to tell your host to recompile php with those settings

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

The latest Magento releases don’t require mysqli extension anymore.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top