Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

No input file specified / godaddy
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

Ok so at first I was getting the “no input file specified” when I would go to http://www.mypage.com/magento/install
I did the godaddy fix’s to the htacess file and the php5.ini file..

so now it gets to the Welcome install page. I click next and I get the same “ No input file specified”

it trys to go to index.php/install/wizard/beginPost/

What am I doing wrong?

i used the FTP program with godaddy.com / changed the permissions to 777 in the file manager

Please somebody help

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cyclops19
Sr. Member
 
Total Posts:  134
Joined:  2008-06-11
 

I went to url specified but got to mypage.com Was this your previous site and you intend to change over to a
magento based site ?

If so you will probably have to build your new site using magento on a new domain name or if available new ip address.. ( http://www.anyname.com ) Hopefully in same server .Then when complete kill old site ( making copies of all files ) clearing server of all unnecessary folders files etc.. Then upload another magento to old domain if that is one you intend to use as permanent,then copy over new magento files to it. The easiest way is to only copy over the 2 new _theme files to be used example- ( http://www.anyname.com/html/app/design/frontend/default/default/the_new_theme (-- the_new_theme - file being the one to copy)

http://www.anyname.com/html/skin/frontend/default/the_new_theme --- ( the_new _theme file being the one to copy )

Be aware that there are two files that you will name the same , the skin is the one that is used primarily for css/images files etc , the app is to work on phtml/html/xml/

 
Magento Community Magento Community
Magento Community
Magento Community
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

that was just an example.... my real url is http://www.99centtaco.com/magento/install

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cyclops19
Sr. Member
 
Total Posts:  134
Joined:  2008-06-11
 

I came across this---- A common error, which usually comes up if you’re hosted by GoDaddy, is the no input file specified error.

There’s a couple things you can do to fix this, but we’ll start with the one that usually works.

In your web root directory, there should be a file called php.ini. Rename this to php5.ini.

If there is no php5.ini file. Create the file and upload it to your root directory.

If that doesn’t work, add the following to the end of your newly renamed php5.ini file:

cgi.fix_pathinfo = 1

And if you’re still getting the error, add the following to the top of your .htaccess file:

Options -MultiViews

The first one usually does the trick. If you don’t see this file in there, then create a blank php5.ini file add add the line listed on the second suggestion.

If all of the above has not worked, KEEP your changes, wait exactly 24 hours. Go back to youraddress.tld/downloader and try again. You may just be cached and for some reason it takes a bit longer then I was used to. Keep your chin up!

If nothing above worked, call GoDaddy up and have them either rename this for you, or make sure you’re on PHP 5.

You can find more here --- http://www.google.com/search?source=ig&q;=input+file+site:magentocommerce.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cyclops19
Sr. Member
 
Total Posts:  134
Joined:  2008-06-11
 

I came across this---- A common error, which usually comes up if you’re hosted by GoDaddy, is the no input file specified error.

There’s a couple things you can do to fix this, but we’ll start with the one that usually works.

In your web root directory, there should be a file called php.ini. Rename this to php5.ini.

If there is no php5.ini file. Create the file and upload it to your root directory.

If that doesn’t work, add the following to the end of your newly renamed php5.ini file:

cgi.fix_pathinfo = 1

And if you’re still getting the error, add the following to the top of your .htaccess file:

Options -MultiViews

The first one usually does the trick. If you don’t see this file in there, then create a blank php5.ini file add add the line listed on the second suggestion.

If all of the above has not worked, KEEP your changes, wait exactly 24 hours. Go back to youraddress.tld/downloader and try again. You may just be cached and for some reason it takes a bit longer then I was used to. Keep your chin up!

If nothing above worked, call GoDaddy up and have them either rename this for you, or make sure you’re on PHP 5.

You can find more here --- http://www.google.com/search?source=ig&q;=input+file+site:magentocommerce.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

Yes I know… I have already done all that as well..... anyone else??

 
Magento Community Magento Community
Magento Community
Magento Community
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

i really need to get things up and running. I am still at the point of my first post in this thread.

I can get to the welcome screen, and i click accept and then continue and it goes to the no input file..

Here is my htaccess.. and my php5.ini file… did i do this correctly?

; This file is for CGI/FastCGI installations.
; Try copying it to php5.ini, if it doesn’t work

; adjust memory limit

memory_limit = 64M

max_execution_time = 18000

; disable magic quotes for php request vars

magic_quotes_gpc = off

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off

; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; turn off compatibility with PHP4 when dealing with objects

zend.ze1_compatibility_mode = off

; PHP for some reason ignores this setting in system php.ini
; and disables mcrypt if this line is missing in local php.ini

extension=mcrypt.so
cgi.fix_pathinfo = 1

______________________________________________________________________--

Options -MultiViews
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter on all content
###SetOutputFilter DEFLATE
# Insert filter on selected content types only
#AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

never mind… i got it fixed

 
Magento Community Magento Community
Magento Community
Magento Community
 
scubasjl
Jr. Member
 
Total Posts:  3
Joined:  2008-12-17
 
centtaco - 13 March 2010 01:08 PM

never mind… i got it fixed

Can you share the solution or was it just the cached got cleared.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cyclops19
Sr. Member
 
Total Posts:  134
Joined:  2008-06-11
 

I went to url and It looks like he got site up and running but now it"s down .

 
Magento Community Magento Community
Magento Community
Magento Community
 
miyacrys
Jr. Member
 
Total Posts:  11
Joined:  2009-07-20
 

I am having the exact same problem on the same host… I have tried all of the suggested fixes and I am at a complete loss. Does anyone have any ideas on how to overcome these problems?

 
Magento Community Magento Community
Magento Community
Magento Community
 
joginder89
Jr. Member
 
Total Posts:  2
Joined:  2013-03-13
 

http://www.magentocommerce.com/boards/26245/viewthread/136755/#t422889

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top